Need help? Check out our Support site, then


Comments & 'Leave A Reply'

  1. Nearly all (if not all) other WordPress blogs I look at with various themes (including those which seem to be using Twenty Ten) have any comments and the “Leave A Reply” box displaying at the bottom of the posts on the home page. I like this feature.

    I’m using the Twenty Ten standard theme and I have comments enabled etc in the settings, but they only show as a small link at the bottom of the page and don’t display until this is clicked.

    I’ve gone through all the settings and searched the help/forums but cannot seem to find an answer. I may be missing something simple!!?

    Please can anyone help?

    Thanks,

    Andy

    The blog I need help with is inzim.wordpress.com.

  2. Your site seems to be normal - the comment box does not show on the front page, other wise as your blog gets bigger you would have a large number of comment boxes that most people don't care about.

    The comment box shows up when an individual Post or Page is displayed, click on the title of you single lonely Post and just that Post will show with a comment box at the bottom.

    add a second Post and it should make a bit more sense.

    I have don't remember seeing a blog that had a front page full of comment boxes (I would never go back, I hate extra junk).

    You can use the "more" option to display only part of your Post and then when people click on it to read the rest of the Post the comment box will also be displayed.

  3. Thanks for this auxclass. I was missing something simple (my wife might comment that I'm the one with something missing & simple!!) - confusing clicking the link into an actual post, compared with the front/home page of a blog. Now I've got it. I think my confusion, as you mention, was because currently there is only one post. Thanks for the trouble & putting me straight.

    Andy

  4. You are welcome & Good Luck

  5. Please forgive me, but this is the closest thread I've found to what I'd like to do. I really don't want "Leave a Reply" nor "Leave a Comment" showing on the blog. Is there anyway to get rid of those sections?

    Thanks for any help you can provide.

    Z

  6. It may be possible to remove it with the CSS upgrade but I do not know that for sure. CSS is theme specific at WordPress.com

    Since there is no official Staff support for the CSS upgrade, and precious little Volunteer support, I recommend that you don’t buy the upgrade unless you have at least moderate understanding of HTML and CSS because you must be prepared to do the work on your own.

    If you are considering purchasing the upgrade, you can go to Appearance > Edit CSS. There wordpress has provided a preview function where you can try before you buy.

    http://en.support.wordpress.com/custom-css/
    http://en.support.wordpress.com/editing-css/

  7. With the theme you are using presently, you can hide the comments link via CSS as below.

    .comments-link {
    display:none;
    }

    Do not that as Timethief says, CSS is theme specific and this is not possible on all themes. It depends on how the original theme designer set up and organized the markup (XHTML) and the CSS.

  8. And actually, the following would be better because it also gets rid of the " | " at the end of the categories.

    .comments-link, .meta-sep {
    display:none;
    }
  9. desertelderlaw
    Member

    Hi - I tried thesacredpath's suggestion on TwentyTen, and it removed the leave a comment button on the home page when I did the preview (I have not yet purchased the upgrade); it did not, however, remove the "reply" box on the two other pages I have.

    I want to completely eliminate the ability of readers to reply or comment on any of my pages. Can I do that by upgrading and editing the CSS?

  10. Go to settings discussion and disable comments in the top section on that page and save. This will only affect pages or posts created from this point forward. You will have to manually turn comments off for existing pages and posts. This is most easily accomplished by using the "bulk edit" function.

    For pages: Go to pages > pages (where it lists all your pages) click the checkbox on the left end of the title bar area for the list (that will select all pages) go to the bulk actions pulldown and select "bulk edit" and then click the "apply" button. In the window that opens, disable comments and save. If you have more pages than are listed on that first page, go to page 2, 3, etc. and do the same thing.

    The same process above works on the posts > posts page as well.

    http://en.support.wordpress.com/posts/edit-posts-screen/
    http://en.support.wordpress.com/pages/edit-pages-screen/

  11. desertelderlaw
    Member

    Thanks! It worked perfectly!

  12. You are welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic