Need help? Check out our Support site, then


Comments and Replies

  1. thewhiskeydiary
    Member

    Hello,

    I'm actually fairly new to blogging, and completely new to customizing a blog.

    What I'm having trouble with is "comments" and the "leave a reply" box.

    I like the idea of enabling readers to comment on my blog posts, which I've set on a separate page than my frontpage, which I wanted as a static Home with a brief introduction.

    On the homepage, I want to disable/delete the entire "leave a reply" box. I just can't see why I'd want replies to come up on my static homepage.

    On the blog page, I want readers to be able to comment on posts. But the "leave a comment" button is thrown in at the end of post tags, and isn't exactly the most obvious/visible link for a reader to follow.

    I'm using the "Twenty Ten" template, and I've been trying to search for an answer to this problem but so far nothing has worked. I'd really appreciate any help that can be thrown my way,

  2. Some themes have the comment tab on top, others on the bottom. How visible the tab is in either case is theme dependent.

    In some themes, it might be possible to buy the CSS upgrade to make the comments button more accessible. But don't buy the upgrade unless you have CSS experience: there are only a couple of volunteers who help with questions about that.

    How about adding a text widget to your sidebar to let visitors know how to comment on your posts?

    To turn off comments on a specific post or page, have you tried this:
    http://en.support.wordpress.com/enable-disable-comments/

  3. In order for us to give suggestions applicable to your blog specifically, please always leave a link to your blog OR link your blog to your username (on your Profile page, under Website).

  4. thewhiskeydiary
    Member

    Oops, my mistake:

    thewhiskeydiary.wordpress.com

    Thank you for the replies, 1Tess you really helped with that link...

    Although...

    I think I was messing up when trying to open the page for editing...I was looking under the Pages tab, and was trying to disable comments via "discussion" in the Settings tab...

    What I needed to do was use the Bulk edit option, and now that I have I can get this sick puppy off the ground.

    Thanks again! Priceless advice :)

  5. I'm having the same issue for my static landing page even though according to the support article at http://en.support.wordpress.com/enable-disable-comments/ my settings are correct

    Pingbacks and trackbacks are not allowed in discussion settings and the screen options on the page do not have comments selected. I see no option for discussion module within the edit screen for my page. The leave a comment box will not go away for the static home page.

    I'm also having an issue with the menu showing published page titles instead of the titles of the menu I've established, but I guess that's for another forum topic.

    electropympin.wordpress.com

  6. @ thewhiskeydiary
    Happy to have helped!

  7. @edm4atx

    I'm not able to reproduce the problem of not being able to turn off comments on a static front page.
    Are you sure you update the page after un-selecting "allow comments"?
    If you quick-edit that page is "allow comments" checked?

    (Yes, for the other issue, please start a new thread: easier for everyone to find it that way)

  8. thewhiskeydiary
    Member

    @edm4atx

    I was getting lost when trying to tinker with the discussion settings as well... follow 1tess' original link (tp://en.support.wordpress.com/enable-disable-comments/) and try following the steps under "Bulk Edit"...That was the only way I could disable comments. I know how frustrating this is I spent an entire day fighting with it, let me know if it works for you. Although the link says change the options for "comments and pings" my dashboard only shows "comments".

    I selected "do not allow" and clicked "update" and now my site looks like this:

    thewhiskeydiary.wordpress.com

    Good luck!

  9. panaghiotisadam
    Member

    Perhaps this will help you clear things up:
    http://wpbtips.wordpress.com/2010/04/23/comments-off-1/

  10. @1tess I have checked and updated and checked multiple times. The option is not selected anywhere for my homepage. This is also happening on my "about" page

    @thewhiskeydiary I tried following instructions listed for bulk posts. (they were instructions for posts not pages). Not sure if that made a difference, but pages did not do anything when I clicked apply. Just loaded the same list of pages with no options. Again, screen options on pages dashboard does not have comments selected.

    I'm using google chrome, would that make a difference?

  11. @panaghiotisadam checked out the article and though it does seem helpful for others it is not for me. I'm using the greyzed theme and it doesn't say anything about that. Plus my settings are correct according to the article. All options for comments are not ticked.

  12. panaghiotisadam
    Member

    a) Those options aren't theme dependent.

    b) If you had read the article, you would have learned that changing the Settings doesn't affect posts or pages already published. Same article explains what to do to disable commenting on an already published post or page.

    c) If you want to do it for several or all pages at once, bulk editing is faster. You go to Pages, tick the square next to Title to select all the pages, select Edit from the Bulk Actions pulldown, click Apply, select "Do not allow" from the Comments pulldown, click Update.

  13. @panaghiotisadam Already tried c, nothing happens when I click apply for bulk edit. Whether there is one or multiple pages selected, I click apply and nothing happens.

    I did review the article again and changed auto close for posts older than...days to 3. It was previously set to 14 and I've only been working on this for 5. Viewed the pages again, the post a reply box is still there. I'm getting pretty frustrated with this at this point. I do appreciate the help from every1 though.

  14. panaghiotisadam
    Member

    And you also tried hovering under the page title in Pages, clicked Quick Edit, and the option Allow comments is unchecked? And you also tried the regular page editor, and both "Allow comments" and "Allow trackbacks and pingbacks on this page" are unchecked in the Discussion module? If so, you should contact staff:
    http://en.support.wordpress.com/contact/

  15. success! Thank you so much @panaghiotisadam the quick edit allow comments was checked!

Topic Closed

This topic has been closed to new replies.

About this Topic