Need help? Check out our Support site, then


Comments are off. Why?

  1. Why does my site not allow for comments? When I click on "leave comment" in any given post it says "comments are closed." When I go to edit the post to make sure comments are enabled, I don't even see the option under the text to allow comments? I have the discussion settings set to allow comments on new articles. Everything in the settings seems to be fine. But I can't enable comments in each post and visitors can't leave comments. Any help?

    Also, why have youtube ads suddenly started appearing on my blog and how can I get rid of them?

    Thank you

    here is my site:
    http://wsantosblog.com/

    The blog I need help with is wsantosblog.com.

  2. All WordPress blogs by default have comments open on all pages and posts in the blog.

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    NOTE: The way the comments function is coded into the core of WordPress and we cannot change this. Unless you use P2, a twitter-like theme, comments are collapsed on the front page of your blog where our posts are "showcased". By clicking the post title or the comments link the posts on the front page open on their own page where all comments display.

    The reason for this structure is that in a new blog one does not have many posts or comments. In an established blog if the comments did not collapse on the front page it would become a mile long in no time flat and page loading time is a page ranking factor. We have only seconds before visitors refuse to wait and click out.

  3. Also, why have youtube ads suddenly started appearing on my blog and how can I get rid of them?

    To off-set the costs of providing free hosting to millions of bloggers, WordPress.com has been running advertising on our free hosted blogs since 2006. Many bloggers do not know this because despite the fact they ticked the box required to get a free blog, they did not read the ToS. Many also do not read the advertising entry in the support documents after registering their username and blog(s). Also note that as the ads do not display to us when we are logged in, and as many use browsers with ad blockers when logged out, they may not realize they are there at all.

    10. Advertisements. Automattic reserves the right to display advertisements on your blog unless you have purchased an Ad-free Upgrade or a VIP Services account. http://en.wordpress.com/tos/

    If the ads you see are found at the end of blog posts then provided you see this link small About These Ads link what you are seeing is WordPress.com generated advertising.

    To eliminate all advertising on our free hosted WordPress.com blogs we can purchase an annually renewable No-Ads upgrade.

  4. Your posts aren't all the same: on some posts the "leave a comment" link is present and you can comment, on some posts the link is present but you can't comment, on some posts there's no link at all. First case means comments and pings are enabled; second case means comments are disabled but pings are enabled; third case means both comments and pings are disabled.

    c) To correct the posts, go to Posts > All Posts and bulk edit them: click the little square next to "Title" to select all the posts on the page, select Edit from the Bulk Actions pulldown, click Apply, select Allow from the Comments pulldown and the Pings pulldown, click Update. Repeat procedure for page 2 etc of your posts.

  5. Thank you for the comments help. Setting discussion on the "screen options" window fixed the problem. Does this mean I have to open each post and check this option on all of them? Do I have to click this option every time I post a new article? If so, then what is the point of allowing comments by default in the settings window? Thanks

  6. Thanks justpi. That made the whole process a lot easier.

Topic Closed

This topic has been closed to new replies.

About this Topic