Need help? Check out our Support site, then


Comments Form

  1. The comment form is not displaying on my home page under my posts, comments is enabled in my dashboard. How can I get the comments for to appear under all my posts?
    Blog url: http://thejesusgeneration.wordpress.com/

  2. Comments on all pages and posts on every WordPress blog are enabled by default. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

  3. I visited your blog and yes comments are enabled on your posts. By clicking the post title or the comments link the posts on the front page open on their own page where all comments display. The comments function is coded into the core of WordPress and we cannot change this. Unless you use P2, a twitter-like theme, comments are collapsed on the front page of your blog where our posts are "showcased".

    The reason for this structure is that in a new blog one does not have many posts or comments. In an established blog if the comments did not collapse on the front page it would become a mile long in no time flat and page loading time is a page ranking factor. We have only seconds before visitors refuse to wait and click out.

  4. I noticed your maybe copying and pasting text into posts.

    Copying and pasting text from elsewhere without using either icon 5 or icon 6 in Row 2 of the visual editor is what the issue is. See: http://en.support.wordpress.com/visual-editor/#pasting-text

    Go to Settings > Writing and select “ ___ WordPress should correct invalidly nested XHTML automatically” and then scroll down and click “Save Changes.”

    Posts > All Posts, change all your latest posts to Draft, click Update, change them back to Published, click Update again. (You can edit all 3 of them at once: tick the square in front of their titles then select Edit from the Bulk Actions dropdown and click Apply.)

  5. Thanks timethief for your replies and help. I'll take your suggestions onboard and hopefully the problem will be resolved, thanks jjreh1

  6. You're welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic