Need help? Check out our Support site, then


Comments marked as spam aren't really spam

  1. This is happening more and more frequently. Comments that aren't spam are being marked more as spam. No matter how often I despam them. Many of them are from the same people, but it seems to happen to most of my recent comments. I tried enabling the approve any comment of a pre-approved author with no success.
    Here's my blog post about it:
    http://aishel.wordpress.com/2007/01/03/blog-comments/

    Is there a way to fix this? A way to make a whitelist?

    Thanks

  2. I've had this same problem. It's my own comments being treated as spam.

    I posted about it on my blog:

    http://fracas.wordpress.com/2006/12/30/fracas-is-not-spam/

    and I posted in this thread here:

    http://wordpress.com/forums/topic.php?id=6419&replies=22

    The other member having the same problem says his seems to have resolved itself and he's going to mark the problem as resolved. My problem as of five minutes ago, is still unresolved so I'll be waiting to see what happens or if anyone has an answer for us.

  3. Aishel, if you're making comments from the same computer that you posted this from, it's probably because your school has no Reverse DNS on your IP address. You need to take that up with your school because it's the sign of either a spammer or system admins who aren't doing their jobs. As to the

    Staff has suggested many times in the past that if you send in a feedback with a link to a specific post that was labeled as a spam, that they would look into it. I would suggest doing so.

    That and searching the forums next time before posting. ;)

  4. drmike, today was the first time I was at school in over two weeks. And the problem isn't ME that is making comments being marked as spam. The problem is OTHERS making comments on my blog.

    The following are examples of comments that were marked as spam, but weren't:
    http://aishel.wordpress.com/2007/01/03/blog-comments/#comment-650
    http://aishel.wordpress.com/2007/01/03/blog-comments/#comment-652
    http://aishel.wordpress.com/2007/01/02/brasserie/#comment-648
    http://aishel.wordpress.com/2007/01/02/brasserie/#comment-649
    http://aishel.wordpress.com/2007/01/01/amazing-astronomy-picture/#comment-647
    http://aishel.wordpress.com/2007/01/01/romance-in-the-blogosphere/#comment-636
    http://aishel.wordpress.com/2006/12/26/guns-n-rabbis/#comment-601
    http://aishel.wordpress.com/2006/12/26/guns-n-rabbis/#comment-603

    To name a few :)

    And I tried searching, but apparently I didn't use the right key words.

    Thanks for looking into this, I appreciate it.

  5. I would suggest sending in that list via feedback as I suggest. Without knowing more information that I would have to get from the backend, there's little we can do here in the forums.

    But your missing rDNS is an issue. I'm surprised you're not having this issue as well if you're posting from school.

  6. I think the issue with my school is that they have open wireless access throughout campus, and I was using my personal laptop. [shrug]. In any case, I wasn't trying to post on other wordpress blogs from school, so I don't know what the deal is. I'm home now. Anyway, I'll use the feedback feature as you suggested.

    Thanks for your time.

  7. Whoah, there's no feedback link anymore. Is that just me?
    Screenshot:
    http://i13.tinypic.com/2jds6ld.jpg

  8. I've sent in five in teh last hour. Something may be up since the holiday changed and they put it back in. I would try the forced-reload of the page. If that doesn't work, you can email via support at this domain.

  9. Not sure whats going on. I deleted cache, cookies, everything. No feedback link. Can I use the support link?
    http://wordpress.com/contact-support/

  10. Since misery loves company, I have to say I'm glad to see others having the same problems as me. I just started with WordPress a few days ago and it is only MY OWN comments which end up in the spam section...not only on the blog I created, but also if I post on others.

    Since the blog I created is a private one and no one can access it unless invited, is there some way for me to disable the spam filter and alleviate this problem? I honestly thought that maybe it would take a day or so before the Akismet "learned" that my comments aren't spam. Then again, maybe Akismet is telling me something about the quality of my comments. ;)

  11. Aishel, you can also send in an email to support at this domain. That will work as well.

    Good, your ISP is known for it's comment spam problem (and many other problems that I won't go into here. I have large chunks of it blocked off from my own boxes going back for many years) although there's no way to tell if that is what is occuring here. Bets bet would be to do as suggested up above and send in a feedback with pointers to the comments that are getting caught. Staff can see your blog.

    Regards,
    -drmike

  12. Thanks drmike for your continued responses. I submitted my support question on that link, and the only response was that I should keep on despamming them so that Akismet learns that they aren't spam. Most of the problems seem to be coming from friends who are commenting from http://*.baltiblogs.com. But there are a few other ones that also get marked as spam.

    And BTW, I tried doing a forced refresh on my dashboard, and there still isn't a feedback link. Oh well.

  13. Thanks for the response, drmike! I knew switching here from Blogger was a good idea...and the feedback is yet more proof. Figures my ISP would be one of the 'fun' ones! Will do as you suggested and see what happens. :)

  14. Aishel, if you're talking about trackbacks instead of comment spam, please note that if you discuss the matter with staff again.

    You can also send in email to support at this domain. I think those are going though and will be dealt with once staff returns on Monday.

  15. drmike, what I meant was that my friends who are commenting have blogs of their own at the baltiblogs URL's. It seems that when they insert their link in the comment form, it gets marked as spam more.

  16. It may be because the Akismet scripts have noted that baltiblogs has a history of hosting spam sites. I don't know right off. A quick search via Google shows a number of them hosted over there that are active. I know when I see them on my own WPMu sites and the ones that I host, we try to shut them down asap.

    You need to send in a feedback. This is not a matter that we can deal with here in the forums.

  17. I thought I should come back and let you know that my problem has resolved itself.

    I had dutifully gone to others' wordpress blogs, posted comments that I knew would be eaten by Askimet and then waited for them to retrieve them and note it so I could have examples. I saved my examples to a word doc and when I thought I had all the info that would help the support folks, I was going to send it in through feedback as is advised here.

    It was however, a weekend (this past one) and so I thought I'd do it on Monday. One thing led to another and it was Wednesday before I could make time to do that. When I logged in to my blog on Wednesday (yesterday), I realized that my own comments weren't automatically sent to Askimet in my own blog anymore! At other WordPress blogs, I'm also back to being able to post again without my comments being sent to Askimet.

    So, I don't know what happened, but I do know that for more than a week I was definitely being caught as spam by Askimet over and over. Perhaps it takes that long to get back into the good graces with the Askimet after being flagged bad? Whatever it is, I'm pleased. If it's just a matter of being patient until Askimet re-learns that a person is ok, then the solution is to find another blogger you know at WP and post comments that they know are in the bin, as well as post comments in your own. If both of you then, are retrieving your comments, it seems after a time, Askimet will learn you're ok again.

    That's a good thing.

    Hope this helps someone else.

  18. Thanks for posting your report. I'm glad to hear all is well with your comments now. :)

  19. I just wanted to publicly thank everyone (Mike, Mark, Barry...if those are your real names ;)) that helped with the "comments are caught as spam" AKA CACA (yup, to be read as 'cah-cah'..juvenile, I know, but that's how it made me feel...like caca. ;)). Thankfully everything seems to be happily resolved, despite a little temporary glitch today. Thank you, thank you, thank you, WordPress!! Indeed SO MUCH better than Blogger. :)

  20. YAY! Another happy ending.

  21. my comments are being marked as spam please help

  22. If your own comments on your own blog are:
    (1) Go to your Akismet spam filter and mark your comment "not spam. => Dashboard => Comments => Akismet Spam and then click the "De-spam marked comments button.
    (2) You must do this several times until Akismet learns your comments aren't spam.

    If your comments on other blogs are being marked as spam the other bloggers in question must do what you have done (1) and (2) until Akismet learns that your comments are not spam.

  23. Hello,

    My problem is that Akismet doesn't leave me anything to inspect; every day it says another 10 or 20 or so messages have been detected as spam, and they are gone. Now people are telling me they left comments, and they never show up.

    I left one comment by myself today, the Akismet counter incremented one, from 83 to 84, and there was nothing there, no comments, nothing to check, all gone.

    I want to see the spam before Akismet deletes it. How can I accomplish this?

    Thanks for your help.

  24. I answered this in your other thread.

Topic Closed

This topic has been closed to new replies.

About this Topic