Need help? Check out our Support site, then


comments not appearing

  1. Comments that have been left on my blog are not appearing with their parent post. I can see the comments on my dashboard and also on my blog's Recent Comments widget. They aren't marked as spam and I still get my notification e-mails telling me that I've got new comments. http://romantichistoricallovers.wordpress.com

    The blog I need help with is romantichistoricallovers.wordpress.com.

  2. Have you approved these comments?

  3. Yes. The blog does not require administrative approval but I did anyway.
    This is not a new blog. It is a new problem.

  4. I just added the sidebar comment widget and only own test comment is showing up on it.

  5. Ops! of course they are approved if they appear in the Recent Comments widget. Please be specific about exactly which comments are not appearing on the posts as I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.

  6. Strangely, comments are working on the other posts just not today (homepage)

  7. "Leave reply " does not come up when you try to comment on home page.

  8. I am using Firefox 20 and this is what I see on the sidebar of http://romantichistoricallovers.wordpress.com/
    Recent Comments
    romantic historical … on A chat with SUZAN TISDALE
    Mary Beth Bass on Highlander Most Wanted by Maya…
    Lee Anne on Highlander Most Wanted by Maya…
    suzantisdale on Highlander Most Wanted by Maya…
    Lee Anne on Highlander Most Wanted by Maya…
    ellaquinnauthor on Highlander Most Wanted by Maya…

    But you say this:

    I just added the sidebar comment widget and only own test comment is showing up on it.

    If you are referring to another blog please post the URL starting with http://

  9. Are you sure you have enabled comments? Please confirm your settings.

    All wordpress blogs by default have comments open on all posts and pages. It looks like you have disabled comments on your posts and pages must enable them.

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    Also make sure that the option "Automatically close comments on articles older than___ days" is not checked, and that the options "Allow link notifications from other blogs" and "Allow people to post comments on new articles" are checked.

  10. Everything was set up correctly. I have deleted the post and re-posted (cut and pastedmy content) Now is is working again.

  11. That's very odd and I'm leaving the tag up for Staff as they may be able to detect what caused this. Please do not permanently delete the post from Trash. Please provide the title of it so they can check it out.

  12. @ romantichistoricallovers - if you can let me know what post was giving you trouble, I'll be happy to take a closer look.

    Thanks!

  13. Hi!
    I just moved it from trash to drafts for you.
    A Chat with Suzan Tisdale :http://romantichistoricallovers.wordpress.com/?p=3920&preview=true

    Vicki

  14. I checked the draft and there doesn't seem to be anything in the code or settings that would cause the comment box to not display. In fact, previewing the draft shows the comment box too.

    It might have been a weird hiccup that caused this as I can't seem to replicate the problem. If this happens again, leave the post published as is and contact us again so we can see what is causing this to happen.

    Also, feel free to delete that draft post.

    Let me know if you have any questions.

Topic Closed

This topic has been closed to new replies.

About this Topic