Need help? Check out our Support site, then


Comments off?

  1. I just published a scheduled post and it says "comments off". I added one myself as a test by editing the post, but nobody else can and I can't for the life of me find a setting related to this?

    Since I'm asking for feedback to the post, this is rather annoying....

    The blog I need help with is colourcottage.wordpress.com.

  2. There have been a few reports of this happening. Please see my earlier forum reply here and if those solutions don't work for you, please come back to this thread and let us know.

    http://en.forums.wordpress.com/topic/closed-comments

  3. I found it myself. I never use the Sreen options up top, but I found in the help pages that the Discussion module can be shown or not shown, and it had

    A. been hidden
    B. when I activated it, the post was not checked to allow comments.

    Since I haven't tinkered with my editor, it must be a glitch in your programming, some update gone askew?

  4. I just checked the other two unpublished posts I worked on yesterday and now the panel is showing, they have check marks. So I don't know what was different.

  5. I have been having a similar problem, with my post on Monday and my post today. I guarantee I didn't uncheck any of the settings to allow comments, either globally or on either of the individual posts.

    Once I was alerted to the fact that my comments were closed on Monday's post, I double-checked that comments were allowed on all draft and scheduled posts, including today's. But when today's scheduled post went up, the comments were closed.

    I've turned the comments back on for individual posts but I agree that there's a glitch in the programming somewhere.

  6. Hello there,

    All WordPress blogs by default have comments open on all Pages and Posts. You can enable and disable comments on free hosted WordPress.com blogs on this page > Settings > Discussion

    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    You can override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    See also http://wpbtips.wordpress.com/2010/04/23/comments-off-1/ under "Faster way" and "Even faster"

  7. @fyreflybooks
    I tagged this thread to bring Staff attention to the glitch you experienced as I have experienced it as well on my blogs.

  8. We are aware that the comments are not showing up as enabled on new posts for some users but have not yet pinned down the cause.

    When each of you are writing new posts, where do you start the posts? In the quick post editor, on a mobile device using the app, or in the traditional post editor window?

    If comments are showing as off for your posts, you may need to turn them back on in your editor window in the box labeled "Discussion". If that doesn't appear, check your Screen Options in the top right corner of your window, just under the admin bar, to make sure that box is set to show up.

  9. I start posts (and publish them) almost exclusively in the traditional post editor.

  10. Traditional editor, PC. For now it's just the one post, I've checked the other two scheduled posts, so far they have normal settings.

    SO - I tried to start a new post using the Quick draft in the Dashboard as I knew I'd tried it out once or twice. And lo and behold, when I open it in the advanced editor, comments are OFF. The Discussion panel was still visible, but both checkmarks gone. So I guess it's the quick editor that is the culprit.

  11. @colourcottage, that's been my suspicion, but I haven't been able to prove it conclusively.

    @fyreflybooks, when you say "almost exclusively", have you noticed any pattern? If you use the post editor window within the Dashboard, are your comments still turned off, or are they only turned off when you use the quick post option?

  12. @jackiedana
    I have a strong dislike for the area referred to as the "new dash" and I never ever use the "new dash" link at http://wordpress.com/post/ to create my posts. I create every post only on each blog's dashboard at:
    http://onecoolsite.wordpress.com/wp-admin/post-new.php
    http://onekoolblog.wordpress.com/wp-admin/post-new.php

  13. @jackiedana - The two posts which were published with comments off (on Mon 12/16 and Wed 12/18) were both done entirely in the post editor window (/wp-admin/post.php?post=xxxxx&action=edit). The more that I think about it, I don't know that I've ever used the Quick Post option - maybe once when it was introduced to start a new draft?

    I do use the "Quick Edit" on the "Posts" page (/wp-admin/edit.php) to change dates/times of scheduled posts and update tags etc., and both of the two problematic posts were probably edited that way at some point.

    The post that I published today was backdated to yesterday, and went live with comments working normally. So either someone has squashed the bug, or it may be an issue with scheduled vs. regularly-posted posts?

  14. That's interesting. We have reported a bug with the comments being turned off if you use the quick post option.

    If you continue to have issues with your comments not being on by default when you use the full post editor window, please let me know. If you notice a pattern (e.g. it happens just on scheduled posts, or whatever) that will be helpful as we try to reproduce the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic