Need help? Check out our Support site, then


Contact Form--Can't get email notifications to send to different email address

  1. Hi,

    I have a contact form on one page of my blog, and I want the results of the form to be sent to an address that's different from the one I use to login. According to the instructions (http://en.support.wordpress.com/contact-form/), all I need to do is enter the email address in the email notifications tab of the Form Builder dialog, but that doesn't work.

    I enter in the address, hit save, and it says saved successfully. Then I click Insert into Post and it returns to the page editing screen. But although the short code for the form displays all of the fields in my form as well as the subject line I added, it doesn't show anything for the email address it should be sent to. Then if I click the form button to edit the form again, in the email notifications tab, the subject is still there, but the email address has disappeared.

    For the life of me, I can't get it to save, even though it says it's saved. Is there a short code for the "to" field that I can enter manually?

    The blog I need help with is mayonbackpackers.wordpress.com.

  2. Incidentally, I'm having the same problem as this guy: http://en.forums.wordpress.com/topic/why-wont-the-contact-form-email-go-where-i-direct-it?replies=4#post-965232

    But no one's resolved it there either.

  3. Nevermind. I found the problem. Here's what's up:

    For whatever reason, putting the info in the email notifications tab on the Build a Form dialog wasn't getting it into the shortcode. Instead, it just showed this:

    [contact-form subject='RESERVATION']

    Changing the subject line(mine was "RESERVATION"), but not the address it gets sent to. I found some outdated shortcode related to ua forms, and tried guessing the commands and inserting a "to" field on my own, as a seperate entry, but it didn't work. It just showed up as text on the page.

    To get it to work, it has to be in the same entry with the subject line. Here's what the shortcode should look like:

    [contact-form to='[email redacted]' subject='YourSubjectHere']

    For mine, this is the first entry, before any of the fields in the form. I'm not sure if there are other ways to do it. Hope this helps anyone having the same problem.

  4. Hey there,

    When I create a form, "to" is specified properly:
    [contact-form to='phil@example.com' subject='Testing'][contact-field label='Name' type='name' required='1'/][contact-field label='Email' type='email' required='1'/][contact-field label='Website' type='url'/][contact-field label='Comment' type='textarea' required='1'/][/contact-form]

    Can you give me a little more information about your environment (operating system and browser version), so I can try to reproduce this issue there?

    Cheers!

  5. Thank you for that!

    My form was generated without the to='[email redacted]' section, so it was picking up the email address from somewhere else.

    Inserting the parameter manually resolved the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic