Need help? Check out our Support site, then


Content Transfer Issues?

  1. Well I finally had luck moving my site off WordPress.com to my own hosting using WordPress.org. Thanks to those here who provided some helpful information. I have been exporting ALL content, month by month from my WordPress.com to my hosted WordPress.org site, http://www.the6thfloor.com. Unfortunately I still have some issues.

    First, is it common to lose page formatting? I am noticing that all the posts and pages I have transferred have lost their formatting. Images aren't in the correct location and I seem to lose all paragraph breaks.

    Second, I am noticing I am still getting comments on my WordPress.com site, but not my WordPress.org site. I attempted to transfer from some new comments to my hosted site, but nothing has shown up.

    Finally, is there a correct way to close down my WordPress.com site so everyone visits http://www.the6thfloor.com, which is where my WordPress.org site new now hosted.

    If some of these are WordPress.org directed I apologize.

    The blog I need help with is the6thfloor.wordpress.com.

  2. Howdy!

    1) No, I wouldn't say it's common. There are things in place at WordPress.com that do not have direct equivalents yet on the WordPress.org side...so you may be seeing some of that. Do you have any specific examples? I'd be happy to take a look.

    2 & 3) I'd recommend considering the Site Redirect feature:
    http://en.support.wordpress.com/site-redirect/

    It's pretty slick as it seamlessly redirecting your readers over if you're using the Day and Month permalinks setting in Settings->Permalinks in your new site. Alternatively, you could put a big fat "Go here!" post at the top of your old blog. If you do that, be sure to set your search engines option in your old blog to "No Google" at Settings->Privacy.

  3. Hi and thanks for the reply. I completely missed the site-redirect feature.

    As for the export/import issue at hand. So far it has been EVERY post or page that I have important to my self-hosted site. All the paragraph breaks are no longer there, so I must spend time fixing the formatting once the new data is imported.

  4. @stoumi, I have no solutions to offer, but from personal experience the import/export stuff is broken, or at least seriously bent. People are having categories stripped from posts and having to go back in and re-categorize all their posts, images are showing up in the media library multiple times, image URLs in posts are not being properly converted over to the new URL structure. Those are just a few of the issues I've personally seen lately. And it seems to be entirely random as to which issues will actually show up on a particular export/import.

  5. @thesacredpath: Thanks, yeah previously I experienced similar problems with the categories being stripped. Guess I will consider myself lucky this time around. Much easier to go back and reformat each post, too bad it's nearly 10 years of material. Ah well. Thanks again.

  6. You are welcome, and even just reformatting is a pain.

    With the paragraph breaks, open each post, select all the text in the post and then from the "format" pulldown on the left end of the lower toolbar, select "paragraph" and hopefully that will bring back the paragraph breaks with less pain.

  7. I have no solutions to offer, but from personal experience the import/export stuff is broken, or at least seriously bent. People are having categories stripped from posts and having to go back in and re-categorize all their posts, images are showing up in the media library multiple times, image URLs in posts are not being properly converted over to the new URL structure. Those are just a few of the issues I've personally seen lately. And it seems to be entirely random as to which issues will actually show up on a particular export/import.

    I concur with TSP on this. I have exported and imported content back and forth between wordpress.com and wordpress.org over the years without any problems at all. As on March 9th in my case I experienced an nightmare like TSP describes above. I have fixed the replicated categories but the images which also duplicated are a mess. The Media Library searchbox is useless to me and I still have broken internal links in posts to repair.

  8. I contacted staff and they are aware of the issues and are working on getting them fixed. You can "fix" it by downgrading the existing site to version 3.0 and then exporting from there and then import that 3.0 export into the blog here.

  9. @TSP
    That's good to know in case others ask too. Bookmarking!

Topic Closed

This topic has been closed to new replies.

About this Topic