Need help? Check out our Support site, then


copy & paste from Word and keeping formatting intact

  1. I'm using theme Andreas09. My first several pages seemed to copy and paste ok from Word into blog. But now, I loose the font (verdana) and the formatting (size, line breaks...). I've tried saving Word doc in every conceiveable format (plain, rtf, xml, html) and then copy paste but to no avail. I have many articles already in Word I want to upload. What to do? Please.

  2. You can upload Microsoft word documents just like you upload any image. However, Word has extra formatting garbage along with the html coding and if you copy and paste it into the editor you will find that the formatting disappears because the wordpress.com software strips it out.

    You are far better off to use an editor like BlogDesk. You can copy and paste your Word text into it and reformat it in the free offline editor like BlogDesk and then publish it directly to your blog. http://www.blogdesk.org/en/index.htm

  3. FAQ on why not to use Word.

    Which editor are you using on the wordpress side? Either use the normal text editor or the Code tab of the rich text editor.

    I've added the Word tag to this thread so you should be able to look at the previous threads on teh subject. I seem to remember some partial solutions but you're not going to be 100%.

    As noted though, Word kicks out a lot of extra code that wordpress strips out for security purposes and because it's not XML valid.

    Someone please add the 'Word' tag to this thread please? It's not working for me. :(

  4. I'm using the "visual" tab on the wordpress side to paste into, not the code tab. Is there a "normal" that I am not seeing? If I could get 90% I'd be thrilled.

  5. The way it knows which font to use, if it's bold or underlines etc is through mark up tags....you need to use a plain text editor, not a word processor for that. You also need to copy the whole lot INCLUDING the tags.

    <p><strong>This text will be bold and shown in bold if copied with the "p" and "strong" tags</strong></p>

    This text will not be bold if it's copied as text only.

  6. aahh. there we go. i turned off rich text in profile options. that worked. thanks all.

  7. You don't need to turn off the visual editor, just switch to "code" view and paste your code in there. That way you can flick back to "visual" to check it and make minor alterations easily.

  8. Actually some of us do prefer using the standard editor as opposed to using the text rich editor (Tiny MCE).

Topic Closed

This topic has been closed to new replies.

About this Topic