Need help? Check out our Support site, then


creating a page break in a post

  1. cassandramarie
    Member

    I've posted a step by step guide with pictures, and I essentially need to be able to "push enter" to create at least one blank line between each step, but NOTHING works. I've pushed enter in visual, I've used the
    tag (which apparently WP strips out) and tried <p ></p > tags. All to no avail. Its very hard on the reader when there aren't any breaks in the page. Short of creating transparent images to serve as line breaks, how to get some space in there?

    The blog I need help with is cassandramarie.wordpress.com.

  2. cassandramarie
    Member

    I forgot to add my site. The specific post in question is http://cassandramarie.wordpress.com/2009/03/09/tutorial-aged-box-part1/

  3. I see a blank line between each step. Do you want even more space?
    You could add space above and below each picture:
    edit picture > advanced settings > image properties > vertical > type the number you want
    update

  4. cassandramarie
    Member

    There we go. Seems like a fairly clunky way to space things out, but thats my non-logical mind speaking. Maybe there is some logic in it that just doesn't work in my brain. Oh well. It got the job done, so thank you very much!

  5. panaghiotisadam
    Member

    For a blank line you can use this piece of code in the html post editor:
    <div></div>
    Or this, for an adjustable blank space (change the number as you see fit):
    <div style="height:10px;"></div>

  6. Panos,
    When you add the code, and remain in html it works, but if you switch back to the visual editor the code gets stripped.

  7. happypenguinkidswear
    Member

    Thanks for mentioning that 1tess-- I was trying to create spaces between text paragraphs this morning and it wouldn't take. Went to HTML and added <div></div> and changes did not endure. Tried
    </br> and changes did not endure. Finally added some graphics between sections just to create some white space.

  8. panaghiotisadam
    Member

    @Tess: Thanks for pointing this out (doesn't happen with me).

    @Tess & hpk:
    Try this, too, and let me know:
    <div style="visibility:hidden;">ANY_ITEM_HERE</div>
    (Item can be a character, a word, a phrase, an image - anything.)

  9. Panos,
    ok:
    copied the code into html. Saved draft. Clicked "preview". Result: it's strange: "ANY ITEM HERE" does not show up (I didn't switch to visual editor), but the return line space is larger than if i delete the code, save, then preview again. (note, I just left the "ANY ITEM HERE" text there.) Switch to visual editor and back to HTML. That code is not stripped out by the visual editor!
    Published the draft because sometimes "preview" is not accurate. Same results: bigger space, but the text does not show.
    replaced "any item…: with a jpeg from the library. Updated. Viewed site, no picture, but a space larger than if the code was not there.
    Info that may make sense to you?
    MacBook Pro (laptop)
    Mac OS X version 10.5.6
    FireFox 3.0.06
    theme in test blog=sapphire, but I'd tried other themes earlier today.

    This does not happen to you, so what is different?

  10. panaghiotisadam
    Member

    @Tess: I don't know why the blank line gets larger than it should - possibly because with some div commands the line spacing gets disrupted. Does the job, however.

    As for my specs, iMac Intel, OS X 10.4.11, Firefox 3.0.7 (test blog theme changes all the time).

  11. @panos,
    ok. So one can sort of control the size of the space:

    text above here and here and so on
    <div style="visibility:hidden;">ANY_ITEM_HERE</div>
    text below here and here and so on
    <div style="visibility: hidden; height: 1px;">ANY_ITEM_HERE</div>
    text below here and here and so on
    <div style="visibility: hidden; height: 36px;">ANY_ITEM_HERE</div>
    text below here and here and so on
    <div style="visibility: hidden; height: 60px;">ANY_ITEM_HERE</div>
    text below here and here and so on
  12. You might want to try this:

    change the default editor mode to HTML; then apply the tags, and see if they now persist when you switch to the visual mode.

  13. stazybohorn,
    The only option I can find is: setting>profile>Disable the visual editor when writing
    So when I re-enable it, the Visual editor strips the code.
    As long as I stay in HTML, the code works.
    It's odd, but I thought I'd used the code on one of my posts, because I wanted control over how much space would be between lines—and now I don't remember which post it was.
    <div style="height:10px;"></div>
    This works between HTML and Visual editors, but you don't have control over making the spacing smaller.
    <div style="visibility:hidden;">ANY_ITEM_HERE</div>

Topic Closed

This topic has been closed to new replies.

About this Topic