Need help? Check out our Support site, then


Creating form so text gets e-mailed to me

  1. I want to create a "suggestion box" type form on a page. I want users to be able to submit a suggestion to the e-mail I have attached to my WordPress blog. How do I do that?

    Thanks,
    Jill

    The blog I need help with is jillfruchter.wordpress.com.

  2. I should add that I did use the form builder in the editor and that was nice and easy to use. I created one "text area" field. When I hit SUBMIT to send test message, I did not receive in my e-mail. Thanks.

  3. Are you referring to customizing a contact form?
    http://en.support.wordpress.com/contact-form/
    If so then please confirm your settings:
    http://en.support.wordpress.com/contact-form/#notification-preferences
    Also check here http://en.support.wordpress.com/contact-form/#feedback-management
    Have you checked your email client spam/junk mail filter?

  4. Thanks! I actually got it to work, figuring out that I just hadn't tabbed in the editor to set up my e-mail. D'oh! But, now here's the thing...I would like to have the suggestions sent to me (as they are doing), but NOT appear on the site. Is that possible?

    Jill

  5. None of the contact form responses are every posted publicly on the blog. Contact form use provides a means of secure communication between bloggers and readers that does not appear on the blog.

  6. But, it did show up. Hmmm. I believe I tried to see if it showed up in both my logged in and logged out state. Maybe I'm using the wrong contact form? I used the "Insert Form" function in editor.

    I have another question: Can I make the comments areas go away from the bottom of my pages? I want most of the site to look like a website and only blog pages to have that other stuff.

    Thank you so much for your help.

    Jill

  7. Maybe I said that poorly. I meant that although the contact forum publicly displayed on the blog, what your receive will not be displayed publicly on the blog. It's sent to you by email and it's in the feedback in your dashboard.

    This is not a secure contact form.
    http://en.support.wordpress.com/contact-form/
    It's just a static page.
    http://en.support.wordpress.com/pages/

  8. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note 1: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

  9. Yes, I viewed those HELP pages and unchecked those boxes (although they looked different then screen grab) and still this stuff is showing up at bottom of page:
    No comments
    Post your own or leave a trackback: Trackback URL
    Leave a Reply

    Signed,
    Confused

  10. Okay, I used Form in Editor for my CONTACT page. But, it keeps filling in my e-mail address in the e-mail box. Isn't that meant to be the sender's e-mail address that they input?

    Jill

  11. Okay, the CONTACT page is done. Thanks!

    Now I just need one last thing: To get all discussion-related footers deleted. I appreciate all of your help. Thanks so much. If you can still help me with this, that would be incredible.

    Jill

  12. re: contact form

    WordPress.com uses cookies to keep track of commenters so if someone makes a comment on your blog, the next time they come to your blog, unless they have cleared their cookies, WordPress.com will recognize them and complete the details for them. No one else will be able to view those details in comment boxes or in contact forms. The next person who comments will see blank fields. Commenters will not see each other’s details.

    While we are at it the same can be said about the Admin [edit] link. It's only for your convenience and only you can see it and use it while you are logged in.

  13. re: disabling comments on Pages
    Pages - Bulk Closure
    Go to Pages > All Pages, click the little square to select all the pages, select "Edit" from the Bulk Actions pulldown, click Apply, select "Do not allow" from the Comments pulldown, click Update. From: http://en.forums.wordpress.com/topic/how-can-i-omit-the-leave-a-reply-box-from-my-pages?replies=4#post-1067546

  14. Fantastic. Thank you.

    I can't promise I won't be back in touch... ;-)

    Jill

  15. Boo hoo :( Here I was thinking that we were getting along so well together. ;)

  16. Indeed, it looks like I'm not done with you, yet. ;-)

    On this page http://jillfruchter.wordpress.com/usability-qa/ I want to get rid of the Comments bubble and Date posted info. Can I?

    Jill

  17. Don't see timethief around yet, so may I chime in? You can hide those elements, but for that you will need the CSS upgrade. (http://en.support.wordpress.com/custom-design/custom-css/) You can keep the upgrade even if you change themes, but since themes differ, your css will not apply to each theme correctly.

    I will supply the css information here for hiding those elements and you can preview it for free and think about whether it is a tweak worth the annual cost.

    To remove the time stamp and comment logo on the page you specified AND the single post entry, use this:

    .timestamp {display: none;}

    If you want the timestamp, etc. on the single post page, but not on the page you specified, try this:

    .blog .timestamp {display: none;}

Topic Closed

This topic has been closed to new replies.

About this Topic