Need help? Check out our Support site, then


Dashboard says zero pages but i have a number of them

  1. bountifulboxes
    Member

    Developing in the Portfolio theme, I created a number of pages, but Dashboard says I have 0 pages. I noticed this after accidentally deleting all the pages from my menu. I still have the actual pages, but when I look at my menu or try to create a new one, the whole interface for adding pages to the menu (in the middle column) is blank.

    FWIW, the pages are still designated 'private' because I'm still developing.

    Thanks!

  2. You did not specify a blog address or reason for posting when you created this topic.

    This support forum is for blogs hosted at WordPress.com. If your question is about a self-hosted WordPress blog then you'll find help at the WordPress.org forums.

    If you don't understand the difference between WordPress.com and WordPress.org, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It'll help people to answer your question.

    This is an automated message.

  3. Please be aware that you will not receive any support on this site until you post the URL of the site you are referring to, because without the URL we cannot provide accurate answers to any questions posed.

  4. bountifulboxes
    Member

    I am supporting my wife who is creating http://www.princetoncenterforfoodstudies.com, which is hosted by WordPress.com but isn't public yet.
    Thanks!

  5. bountifulboxes
    Member

    Oh, figured it out I think. She made all the pages private, but that was unnecessary because the whole site is private. When we took away the "private" designation from the pages, they show up again.

  6. Thanks for providing the URL so I could verify the hosting.

    Are you referring to Pages or to Posts? The two are not the same http://en.support.wordpress.com/post-vs-page/

    The front page of the blog by default will display your posts (not pages) in reverse chronological order, with the most recently published post on top. The only way that can be changed is by setting a static front page. To do that create two pages > http://en.support.wordpress.com/pages/ After you do that you go to > Settings > Reading and make the designation change and click “save changes”. http://en.support.wordpress.com/pages/front-page/

    If that's not what you mean and you are referring to Pages that are not displaying in the menu bar I suggest you go to > Dashboard > Pages > All Pages and hover over the Page titles then click "edit" and check the page visibility settings in the Publish module.
    edit pages screen http://en.support.wordpress.com/pages/edit-pages-screen/

    Troubleshooting – My Pages aren’t appearing
    They must be public pages – not private and not draft.
    Public – The page will be visible to everyone.
    Protected – The page is protected with a password you set. Only people who have the password can view a protected page.
    Private – Pages are only visible to blog Editors and Administrators. Private pages are not visible in Reader, feeds, or in any search. A page can be private without being password protected.
    http://en.support.wordpress.com/pages/

    If you created a custom menu http://en.support.wordpress.com/menus/ then you can add Pages to it and create the order you want.
    http://en.support.wordpress.com/menus/#changing-the-order-creating-sub-menushttp://en.support.wordpress.com/menus/#adding-pages

    There are many common errors, misunderstanding and misconceptions when creating custom menus and you can read about them here > http://wpbtips.wordpress.com/2011/12/19/custom-menus/

Topic Closed

This topic has been closed to new replies.

About this Topic