Need help? Check out our Support site, then


Delete an unwanted page.

  1. Hmm... I have been trying to delete the page titled, "Blog" from my navigation bar and although it has been deleted as a page, it won't go away. I have not permanently deleted it because I fear that it's tied to my blog and will eventually delete all of my posts of I permanently delete it.

    Please take a look... it's the first link in my navigation bar underneath my logo.

    I think this problem arose after I created a static homepage a while ago. Since then, I deleted the homepage and now am stuck with this Blog link that takes my readers nowhere when they click on it.

    The blog I need help with is marthaleonedesign.com.

  2. The best way to solve your problem is to use a custom menu and then simply remove the page from appearing in the menu.

    Here's information on how to set up the menu: http://en.support.wordpress.com/menus/

  3. Hi Martha,

    Lizthefair offers a great solution. It is important to remember that you have to choose the menu's location or it will default to all pages showing in the menu. The theme locations option is a check box at the bottom of the Edit Menus page. Don't forget to save!

    Let us know if you need any additional help.

  4. Since you already have a custom menu set up, you need to:

    1) Head to Appearance > Menus
    2) Click the arrow next to the Blog menu item to open it
    3) Click "Remove"
    4) Click "Save Menu"

    Screenshot: https://cloudup.com/cII9rydZFAv

    Let us know if you run into any trouble.

Topic Closed

This topic has been closed to new replies.

About this Topic