Need help? Check out our Support site, then


diable like buttom

  1. Hi there,

    I will like to disable all "like buttom" through css, I've been trying to find out how it works in my blog css but I haven't been lucky,

    I thought it is related to

    div.sharedaddy ul.wpl-avatars {
    visibility:hidden;
    }

    but may this code control all sharing buttoms or just the like one...

    Anyone could hel me?

    The blog I need help with is xo-inmyroom.com.

  2. You can do this is the post editor. Open each post in the editor and scroll to the bottom of the screen. There is a checkbox for "show likes for this post". Uncheck it.

  3. As @zandyring says you can do this in the post editor, but it would help if you first select a setting elsewhere:

    If you go to your dashboard, click on Settings, then on Sharing, then scroll down the page you'll see 'WordPress.com Like are' and you can choose between two options:
    On for all posts
    or
    Turned on per post

    If you choose the second one, then you can select which posts (if any) you want to have the Like button showing on.

    There used to be a way to turn them off globally, but that was removed some while ago. (Not by me, I'm a volunteer).

  4. Hi there, thanks to both of you! That was helpful! It's amazing you volunteer to help, thanks!

    Still, I would like to disable like buttom through css edition, so even If I forget to uncheck the "show like" box, likes won't appear.

    Do you know id that's posible? Thanks again!

  5. I just turned off the "Likes" for my blog post about "vegemite" asking readers to go in my Poll (which is in another of my blog posts, together with the history of vegemite), because I don't like people simply "liking" my posts just to get exposure or coverage (i.e. to have their gravatars/profiles there) and I suspect that has often been the case for my posts. However, to my surprise, today I got email notifications that there had been 3 "Likes" of my post.

    I went to the Reader in WordPress and sure enough the Like option is there along with the excerpt of my post.

    I am not actually showing the "Likes" on the actual Post in question, but still I would like the function of fully disabling "Likes" so the option doesn't show up in the Reader, but rather, having the Like option only available at the bottom of a post (and not via the Reader).

    This would stop "likes" from the Reader where the liker has not read the whole post but is just passing by and clicking Like here and there based upon the extracts, simply to get exposure.

    I know that having the "Like" option in the Reader makes it quick and easy to like a post from the Reader, but speaking for myself, I am more interested in Comments than Likes, and if someone really does read and like a blog post, by clicking on the title or "read more" from the Reader, he/she could just as easily "Like" the post from below the Post.

    A word of warning

    If you have happily posted several blog posts with "On for all posts" and then you switch to "Turned on per post", this change will remove all the Likes that your existing posts have obtained.

    So, if you want the Likes for all or some of those to be shown, but not for your new post, then you have to zandyring's method - edit the post and uncheck "Show Likes". :)

  6. Ok then, that has sense!

    The thing is I don't like how "likes" look like at the end of the post, although I'm ok if people want to "like" it through reader or any other way...

    I'll keep unchecking the like buttom!

    BIG THANKS!

Topic Closed

This topic has been closed to new replies.

About this Topic