Need help? Check out our Support site, then


Difficulty uploading image to widget to display in sidebar

  1. I am trying to upload an image to show in my sidebar. I have tried everything I see on the help site, but the image does not show. It shows as an x. I have uploaded to the site and I believe filled out the widget correctly. Thoughts?

    The blog I need help with is sharonmanuel.wordpress.com.

  2. Upload it to where? Your Media Library?

  3. I have uploaded to media library and now wish to attach this image to the widget that will display this image in my sidebar. When I complete all the setup for the widget and go back to look at the page, the image doesn't appear. The title for the image appears, but the image does not. Just an x. Any idea what I am doing wrong?

  4. I have resized the image to make it small enough. And since the image has been uploaded to my media libary, the URL should be ok. So, I must be missing something.

  5. What are you putting in the Widget? And are you using the Image Widget?

    You ARE asking about a wordpress.com hosted site, right?

  6. A jpg image. Yes I am using the image widget. And yes it is a wordpress.com hosted site.

  7. I just looked at mine and it's a straight file name right out of the Library with nothing special added.

    If you'd care to post the image file name here, maybe somebody can come up with a reason.

  8. Give us the URL you're trying to use please.

  9. http://sharonmanuel.wordpress.com/wp-admin/post.php?post=420&action=edit

    This is the URL for the picture I am trying to add to my sidebar using the image widget.

  10. That is NOT the URL for an image. That's the URL for an edit page for a post.

  11. Oh, ok. I uploaded this image as media and thought this would be the right link to use for the sidebar widget. Can you suggest what I should do instead?

  12. What is the URL of the image? In the media library, go find the image, click Show, and scroll down to where you have the actual FILE link. If you have to, change the link to "Link to File" instead of what you have now, which appears to be "link to page". Copy the link to file, which will end with .jpg or .gif or some other image-specific suffix, and put that in the image widget.

  13. Thanks for the input, but I think I am technically challenged. There is no SHOW option to click on and scroll down when I go to the media libary. Also, I do not see Link to File/Link to Page. The file I have uploaded does end in jpg. I have tried a 3rd part site to create an image URL and I cannot seem to get that working either......

  14. For a new file: you upload the image from your computer via Media > Add New then copy the File URL.
    For an image you have already uploaded to your blog: you go to Media > Library, hover over the thumbnail, click Edit, copy the File URL.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.