Need help? Check out our Support site, then


disable comments for old pages not future ones?

  1. Hi
    I created a page and added some content. the comment box (leave a message) is there. Later, i went to settings and I unchecked the option that "allow comments". I went back to that page and I still see "leave a massage" box! but when i create a new page, I do not see that box. Does that mean changing the setting after publishing a page would not effect the old pages only the future pages?

    Thanks

    The blog I need help with is lezawang.wordpress.com.

  2. All WordPress blogs by default have comments open on all pages and posts in the blog.

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note 1: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    Note 2: To disable comments on already-published posts or pages, you can edit each post and uncheck the "Allow comments" setting. See http://en.support.wordpress.com/enable-disable-comments/#enabledisable-comments

    To disable comments on already published pages (not posts), you go to Pages > All Pages, click the little square to select all the pages, select "Edit" from the Bulk Actions pulldown, click Apply, select "Do not allow" from the Comments pulldown, click Update. Same thing for already published posts, in Posts > All Posts.

  3. that is great. thanks for the help.

  4. You're welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic