Need help? Check out our Support site, then


Disable comments not working

  1. Hi

    I just changed my theme to vertigo, and this lead to a few issues involving comments.
    I have a static page as a homepage, and then posts on another page. Ideally I would like to be able to get rid of the "LEAVE A REPLY" on the static homepage, but enable comments on the blog posts. The home page looks really cluttered with the leave a reply, and would like to ditch it, but I can't for the life of me figure out how...

    When I go into options discussion settings, I have all 3 options unchecked, ( Attempt to notify any blogs linked to from the article, Allow link notifications from other blogs (pingbacks and trackbacks, Allow people to post comments on new articles ) yet no matter what I do there is always still a 'leave a reply' option.

    All the support and helps and things say you can alter it for just one article, (edit comments individually per entry) but when i go in to edit any pages (or even posts for that matter) there is no option to disable comments, just to disable sharing.

    Please help :(

    http://carpedeumcarpediem.wordpress.com/

    The blog I need help with is carpedeumcarpediem.wordpress.com.

  2. panaghiotisadam
    Member

    The page editor should include a Discussion module. If you see no such thing, click Screen Options (top right) to activate it.

  3. You cannot change the wording of "leave a reply" or prevent the display of it without CSS editing experience, purchasing an annually renewable CSS upgrade, and doing the CSS editing required to change it.

    Please go to the top right hand corner of your Admin page and click "screen options' and activate all of the modules you see there.

    The default display settings for comments are here > Settings > Discussion
    http://en.support.wordpress.com/settings/discussion-settings/

    We can override default comments settings on individual posts and pages as described here > http://en.support.wordpress.com/enable-disable-comments/
    This is not retroactive so read the instructions found at that link for editing older posts and pages. This is done in the Discussion module under the editor box -- scroll down and look hard for:
    __ Allow comments.
    __ Allow trackbacks and pingbacks on this page.

  4. ~~ Panos :)

  5. Oh ok in screen options. THANK YOU!

  6. Do understand that you can enable and disable comment but without the CSS upgrade you cannot remove the phrase that displays such as "Comments Off" that will appear when you do disable comments. In other words the phrases that are coded into the theme like "leave a reply" or "comments of"" are what you have to live with unless you use CSS to edit them.

Topic Closed

This topic has been closed to new replies.

About this Topic