Need help? Check out our Support site, then


disable comments on home page

  1. I can't seem to disable the comments section on the home page of my blog. I don't want people leaving comments anywhere, but would prefer the blog to appear as a website.

    The blog I need help with is mcreynoldsdesigns.wordpress.com.

  2. Edit Page -> scroll down to the "Discussion" box area and uncheck " Allow comments" -> click "Update" .
    You can do this simultaneously for multiple pages by going on your dashboard menu -> Pages -> check the ones you want to edit -> go to "Bulk Actions" dropdown menu at the top -> choose "Edit" -> click "Apply". A new section will appear: click on the dropdown menu labelled as "Comments", choose "Do not allow" and "Update".
    Also, the method for enabling/disabling comments on posts is the same, you'll just have to go to the Posts section instead of Pages. Here are the support pages: http://en.support.wordpress.com/pages/new-page-screen/#discussion, http://en.support.wordpress.com/posts/new-post-screen/#discussion

  3. mcreynolds1007
    Member

    The problem that I'm having is that on the home page there are two buttons on the bottom "edit" and "comment", but you can't go into "Page" under the dashboard and see a page that says "Home". I've gone into Pages, checked all boxes, clicked and changed bulk to edit, hit do not allow and update. All comment options are gone on the subsequent pages, but still showing up on Home.

    Thank you for responding (above).

  4. I've just noticed: your blog's front page is displaying your latest posts, in your case, a post called "Welcome to McReynolds Designs" (that's why the comment form appears).
    If you want your blog's frontpage to be a static page, on your dashboard menu go to the Settings section -> Reading -> "Front page displays" -> click "Static Page" and choose on of your pages (you should probably create first a page called "Home" with the content from your Welcome post and choose it).

  5. thistimethisspace
    Member

    All comment options are gone on the subsequent pages, but still showing up on Home.

    Let's try and keep this simple. There is only one page you can post to in any blog and by default it's the front page of the blog.

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note 1: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

  6. Ok - I've made a separate page called "Home" and moved the content over from the original welcome post. Now when I go onto the front page it says "Sorry, but you are looking for something that is not there." Is there a way to get the home page to show up as a home page? My guess is that if I send people to this they'll see that message and give up, though some will probably click on home.

    Am I making this harder than it should be? I really do not like computer stuff.

    Than you.

  7. This my blog for all everyone ask question for sex problem kidney stone and specially for paralysis.
    Dr. Parvez Alam

Topic Closed

This topic has been closed to new replies.

About this Topic