Need help? Check out our Support site, then


disable comments on pages

  1. i've read through explanations of disabling comments, but i'm still not getting it! i want to disable comments on my pages only {not posts}. 1 out of 4 of my pages do not show an option for comments, but the other 3 pages all provide a place to comment.

    how do i disable the comment section from these pages?

    thanks for any help!!!

    The blog I need help with is michellegd.com.

  2. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    is it possible to disable commenting just on one particular post?

    We can also override the default settings and enable or disable future comments on any post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

  3. timethief,
    i've read through these articles before your quick response {thank you for that!} and have now read through them again. i have gone under "screen options" to disable the comments...i have unchecked the comment box...it is still showing up.
    ???

  4. i'm sorry to be so dense, but i'm still not getting something. i have the "comments" box unchecked for each of my pages {in the screen options} but the comment box still appears on 3 of my pages.

    {sorry i'm not getting this!}

  5. aidanselephants
    Member

    I've got this problem too - I want to disable comments on all my pages, but still have them available on blog posts. Can anyone help?

  6. Then disable them on each Page as you write it. There's no setting to automatically disable them on Pages but not Posts.

  7. when i look at each page individually {to edit them} i can click on the screen options. there is a box to check what will appear on the page. i have NOT checked comments. so i cannot figure out why it appears on the page???

    any further thoughts?
    {i appreciate your help!}

  8. Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules
    Post – Likes and Shares, Format*, Categories, Tags, Excerpt, Send Trackbacks, Discussion, Comments**, Slug, Author, Revisions, Writing Helper
    Page – Likes and Shares, Page Attributes, Featured Image, Discussion, Comments**, Page Revisions, Slug, Author, Revisions, Writing Helper
    * Format module is displayed if the theme supports post formats.
    ** The comments module will only displayed if the Post has comments.

  9. thanks for all the help with this.
    but...
    i do not have any boxes checked {discussion or comments} yet they appear on the screen...

  10. You said that you have gone to the screen options to disable the comments, but all the screen options menu does is place of remove options from your screen. If you have Discussion unchecked on this screen you cannot manage your comments.

    So please do these steps:

    Go to Dashboard > Pages > All Pages
    From the list of pages choose one that currently allows comments that you want removed and click edit.
    While you have that edit screen up, go to screen options and check the Discussion option..

    Now when you go back down to your page where you can edit your page, a new module on that page will have been added called Discussion. Here you will have the option to check or uncheck Allow Comments.

    Remove the check. Save your page.

  11. bingo! thank you *so* much for spelling this out for me.
    it worked!

    i cannot thank you enough!
    kisses...
    michelle

  12. So glad you got it!

  13. Faster way:
    You go to Pages > All Pages, tick the little square to select all the pages, select Edit from the Bulk Actions pulldown, click Apply, select Do no Allow from the Comments pulldown, click Update.

  14. thank you so much for another trick!!!!
    michelle

Topic Closed

This topic has been closed to new replies.

About this Topic