Need help? Check out our Support site, then


Disable Comments per post

  1. I feel like I am losing my mind *breathe* :)

    I have reviewed the documentation several times for disabling comments on published posts. I've revised Discussion module, per post settings and Page settings but it's not working.

    I want posts which appear in my slider, category Featured Posts, not to have comments. Only the Blog posts should allow comments.

    What I have managed to do is turn off comments for all new posts but of course I am not able to turn them back on. Screen options settings per post have Comments checked but it still doesn't show.

    Appreciate the help!

    The blog I need help with is beginblossoming.wordpress.com.

  2. a) Checking or unchecking "Comments" in Screen Options is irrelevant: it determines whether comments made on a post will show up on the post edit screen or not.
    b) Enabling or disabling comments in Settings > Discussion becomes your new default: it applies to posts and static pages you create after you change the setting, but has no effect on already published posts/pages.
    c) The per-post discussion options override the default setting. So you need to allow comments and pings in Settings > Discussion, and disable them for each individual "featured" post.
    d) For an already published post, you don't need the Discussion module of the post editor: it's faster to go to Posts > All Posts, hover over the post title, click Quick Edit, uncheck the options "Allow Comments" & "Allow Pings", click Update.
    e) But since you want to change several posts, it's even faster to go to Posts > All Posts, tick the little squares to select the right posts, select Edit from the Bulk Actions pulldown, click Apply, select "Do not allow" from the Comments and Pings pulldowns, click Update. (Repeat for the next page of posts, if the posts aren't all listed on the first page.)

Topic Closed

This topic has been closed to new replies.

About this Topic