Need help? Check out our Support site, then


Disappearing widgets in Vigilance style sheet (CSS)

  1. hardrockinhomemaker
    Member

    Hi everyone. My blog is based off the Vigilance style sheet and I am working in Firefox. The widgets in my right sidebar have suddenly disappeared when I updated one of my posts. I tried reverting most of the CSS I changed back to the original, but that didn't help. (The updated post that seemed to trigger this was content-only, no CSS changes anyway.)

    I know that WordPress has been experiencing bugs since last night, but I'm not sure this is related. Incidentally, the color of my titles all changed as well.

    This is my first time posting a question, so if I need to provide additional information, please let me know! Thanks!

    The blog I need help with is hardrockinhomemaker.wordpress.com.

  2. This is most often caused by an open HTML tag in one of your posts.

    Go to settings > writing and select "WordPress should correct invalidly nested XHTML automatically" and then click "save changes."

    Now, starting with your latest post, open it in the editor, make one minor change such as adding and then deleting a space, and then click "update post." Check your blog and if it is back to normal, you are golden. If not, open the next post and do the same thing till it goes back to normal.

  3. The site you reference is using 2011, so I cannot say any further what might be wrong with the colors and such. If you are talking about a different site, please provide a link.

  4. hardrockinhomemaker
    Member

    Thanks for the response. I did exactly what you said, and made changes to every single one of the blog posts. Unfortunately, the sidebar widgets are still missing. Any other ideas?

    I apologize for the confusion. When I posted this question, the system auto-linked to the wrong blog and I didn't notice. The correct blog is hardrockinhomemaker.com (or hardrockhomemaker.com, which redirects to the first). I don't use or want the hardrockinhomemaker.wordpress.com blog referenced above -- I'll fix that so it automatically redirects to hardrockinhomemaker.com. Thanks for that catch.

  5. hardrockinhomemaker
    Member

    Update: I fiddled around some more with the CSS. Long story short, I've managed to get the widgets to appear again, although with the newest (and apparently necessary) changes to the CSS, the blog still doesn't look quite the way I hope. I'll continue to tweak it, but ultimately I have the major problem resolved. I guess I'm still in the "learning curve" part of this!

    Thanks again for taking the time to help me out!

  6. There is no sidebar on single posts in Twenty Eleven and I think you will benefit from reading this article on how the Twenty Eleven theme is designed.

  7. hardrockinhomemaker
    Member

    My apologies for the confusion, timetheif. The post automatically referenced the wrong blog -- I needed help with hardrockinhomemaker.com, not hardrockinhomemaker.wordpress.com. The wordpress.com blog is not in use.

    In any event, I have continued to tweak the CSS in Vigilance and have retrieved the sidebars and reverted the text colors. So my problem is resolved and I updated the status of this post accordingly. Thanks for offering to help, though!

Topic Closed

This topic has been closed to new replies.

About this Topic