Need help? Check out our Support site, then


Discussion settings

  1. Discussion settings not updating - I have deselected every setting on the Discussion Settings and I even deleted the 'Leave a Reply' comment - however when I save and refresh the Leave a reply comment is back and I can't get rid of the boxes on the bottom of each page.

    I have the pro version but still can't get rid of the comments box. Please help.

    The blog I need help with is helenlord.wordpress.com.

  2. Obviously you disabled commenting in Settings > Discussion after you created the pages. Doesn't work that way! The new setting is your new default: it applies to future posts/pages but has no effect on already published ones. You need to go to Pages > All Pages, tick the little square to select all the pages, select Edit from the Bulk Actions pulldown, click Apply, select "Do not allow" from the Comments pulldown, click Update.

    PS Please search the Support docs and the forum before posting questions: this is a standard feature, you can read all about it here, and it has also been answered countless times in this forum.

  3. Thank you very much - that has definitely worked.

    Just to let you know I did search the forum before posting - but didn't realise that Bulk Editing was what I needed - it might be useful to add a comment under the first heading "Enable/Disable comments" to direct those trying to disable comments after a page has been published to the "Bulk Editing" paragraph.

    Like many, this is all new to me and I'm 'feeling my way' around and don't have a lot of knowledge of what I need or what different element are or will do. I really appreciate the support though. Thank you.

  4. You're welcome.
    Bulk editing is useful if you want to change several posts or pages at one, but it isn't the only option when you want "to disable comments after a page has been published". Alternatives:
    1) Pages > All Pages: hover over the page title, click Quick Edit, uncheck the option "Allow Comments", click Update.
    2) Regular page editor: uncheck the same option in the Discussion module, click Update. If you're not seeing the Discussion module while on the page editor screen, click Screen Options (top right) to make it show up.

  5. Many thanks justpi - it's great to have the alternatives.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.