Need help? Check out our Support site, then


Displays a blank page for Log In and Home

  1. My site is http://komicks.com/ , and I cannot access the Log In page to the dashboard, nor simply view the homepage. It's as though the site is non-existent, all I get it a blank page. This is not simply a problem with my internet browsers. This phenomena began a day or so ago, and I have done nothing to update the blog in that time except add a couple posts to my site, so as far as I am aware, I have done nothing to contribute to the websites current state.

    Quite frankly, I'm quite at a loss; I'm not sure if it is a hosting issue or what, and I'm worried if I will have to re-load my website from scratch.

    I'm not the most skilled blogger here, but could anyone offer an explanation of what's going on or please point me in the right direction into fixing this? Although I've tried getting an explanation from someone else. I'd greatly appreciate some feedback from here, thank you.

  2. You did not specify a blog address or reason for posting when you created this topic.

    This support forum is for blogs hosted at WordPress.com. If your question is about a self-hosted WordPress blog then you'll find help at the WordPress.org forums.

    If you don't understand the difference between WordPress.com and WordPress.org, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It'll help people to answer your question.

    This is an automated message.

Topic Closed

This topic has been closed to new replies.

About this Topic