Need help? Check out our Support site, then


Domain Mapping Goes Into Infinite Loop

  1. I just purchased and set up domain mapping for my wordpress blog (dondueck.wordpress.com) so that I can see it under a domain I already own (dondueck.com). I had previously set up my dondueck.com domain (purchased through NetFirms) to redirect traffic to dondueck.wordpress.com, but I decided I'd rather have my wordpress blog's address appear as dondueck.com instead of dondueck.wordpress.com.

    After updating the nameservers on NetFirms and waiting until WordPress saw the change, I added the dondueck.com domain to my WordPress blog. When I set dondueck.com as my primary domain and try to browse to either dondueck.com or dondueck.wordpress.com, however, my browser goes into an infinite loop between the two addresses (with nothing being loaded). If I set dondueck.wordpress.com to be my primary domain, then everything works fine (except for the fact that my dondueck.com redirects to dondueck.wordpress.com instead of vice versa, which is what I want).

    While the infinite loop is going on, the address bar shows:

    http://dondueck.com

    and this is the page source that appears is:

    <HTML> <HEAD><META HTTP-EQUIV=Refresh CONTENT="0; url=http://dondueck.wordpress.com/"> </HEAD> </HTML>
    Blog url: http://dondueck.wordpress.com/

  2. Hmmm... After some more testing, it appears as though Netfirms is still in control of directing where dondueck.com goes to. I tried changing the address that dondueck.com points to under the Netfirms control panel and that seems to be the end result.

    That is, with WordPress domain mapping:

    dondueck.wordpress.com redirects to dondueck.com, and dondueck.com then redirects to whatever I enter under the Netfirms control panel. I was under the impression that, with Domain Mapping, WordPress would have final control over where dondueck.com would end up pointing because of the name server changes.

  3. Actually, you just need to set the domain as your primary via Upgrades -> Domains in your blog's Dashboard. Then, everything should work properly.

  4. As stated in my opening post, that's exactly what I did, but it didn't work, and it prompted this very Support question. I've just changed it back for the time being so I can actually see my blog and work on stuff.

  5. When dondueck.com is set to primary and I try viewing http://dondueck.com/ it works for me without any trouble. I tested with Chrome, Firefox, and Safari on a Mac. It sounds to me like something at the browser or network level is stuck for you. Could you please try clearing your browser cache as a first step? If that doesn't help, is it possible for you to turn your modem completely off and then back on again? If you're still having trouble after that, could you let us know if you're using a Mac or a PC and what browser and browser version you are using?

  6. I tried http://dondueck.com/ on a completely different computer (my PC at home) and different ISP with both Internet Explorer 8 and Firefox 4 and they both resolve to the redirect address I entered in NetFirms (which I changed to google.com).

    http://dondueck.wordpress.com/ redirects to http://dondueck.com/ which then redirects to the address I entered in NetFirms.

    If I change the redirect address in NetFirms, both http://dondueck.wordpress.com/ and http://dondueck.com/ eventually resolve to it. I tried it just now and it worked instantly.

    Trying it all again after clearing my browser cache made no difference.

    I have now left dondueck.com as the primary domain under WordPress and have left google.com as the redirect for dondueck.com under NetFirms (which shouldn't have control over the domain redirect now, right?). Could you try the address again and verify that it is loading up my blog and not google?

  7. I'm not sure exactly what option you are updating at NetFirms, but as long as the name servers are pointed to NS1.WORDPRESS.COM, NS2.WORDPRESS.COM, and NS3.WORDPRESS.COM and you have applied the domain mapping upgrade in your blog dashboard, then the traffic should be controlled by WordPress.com servers and it should route properly. (And it's correct that settings changes other than name servers made at NetFirms should no longer have an effect.) If you changed the name servers back and forth, it's possible you're causing some delays. You should make sure to set the name servers to NS1.WORDPRESS.COM, NS2.WORDPRESS.COM, and NS3.WORDPRESS.COM and leave them. Note that it can take up to a few days for DNS updates to fully propagate throughout the internet. How long it takes depends on how often your ISP updates against the master DNS databases. It varies by location, and that's one reason that some people can see an update right after a change is made and others cannot.

    I checked http://dondueck.com/ again and it is working fine for me right now.

    It sounds to me like you just haven't waited long enough for the settings to propagate. What is the date/time of the last time you made any changes to the DNS settings for your domain? You should wait a at least a day or so from that point and then try checking it again.

  8. These are the settings that I have:

    Netfirms nameserver settings
    Netfirms domain forwarding setting
    WordPress domain mapping settings

    I did not change the nameservers again after setting them to the wordpress ones earlier today (around 1:00pm CST).

    You're probably right about the propagation thing. I'll wait a day or so and see what happens.

  9. Sounds good. Let us know if it doesn't sort out on its own in the next day or so.

  10. I visited dondueck.com this morning and it is now correctly loading up my site. Looks like everything is OK!

  11. Yay!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.