Need help? Check out our Support site, then


Drop-down Menus in the Coraline theme

  1. I've just switched from Cutline to the Coraline theme. In Cutline, links to Pages automatically appear in the header, but not links to Sub-pages (child pages). That's the way I like it, as I sometimes use Sub-pages for material that isn't important enough to be in the header.

    Coraline is a great theme. My only problem with it is with the drop-down menu feature. I've studied the documentation about menus, but I can't figure out if drop-down menus can be turned off for Pages. I want links to the parent Pages to show up in the header (which Coraline does by default), but I'd prefer not to have Sub-pages automatically show up in drop-down menus.

    I went through the process of building a menu of Pages, without selecting the Sub-pages, but they still show up in drop-down menus. Is there any way to control that without shutting off the Page links completely?

    The blog I need help with is sensuouscurmudgeon.wordpress.com.

  2. I'm so sorry but this is not an issue for Volunteers as we cannot help with it; only Staff can and this is what we find at the Staff support link:

    Support is currently closed as staff meet offsite brainstorming ways to make things better. We will be dropping into the forums regularly during the hiatus, and we’ll formally reopen on August 16th. http://en.support.wordpress.com/contact/

  3. @sensuous, with any theme that supports drop down menus, that is going to happen typically, but you can fix that by creating your own custom menu. With a custom menu, you can insert only the pages and such you want into the menu.

    http://en.support.wordpress.com/menus/

  4. ... DUH ... I knew that and forgot ... thanks TSP - I need coffee :(

  5. No problem TT, and I'm out of coffee - cat food's low too). Have to make a trip into town.

  6. thesacredpath says: " ...but you can fix that by creating your own custom menu. With a custom menu, you can insert only the pages and such you want into the menu."

    Right. I've tried that, and only the parent Pages show up in the header. But when you mouse over them, the drop-down menus showing sub-pages still show up. I was hoping someone here had encountered this and worked it out, but I guess it's a question for staff.

  7. Hmmm, that shouldn't happen I don't think if you did not put those pages into the custom menu.

    Try this: Open a couple of those child pages and remove the "parent" to where it is a top level page and see if that fixes it. It could be that the fact it is a child of another page is causing the issue (although it should not).

    See if that works, and then also report it directly to staff. This seems like a bug.

  8. Good suggestion, thesacredpath. Instead of moving a sub-page to be a top-level page, I tested it by just adding a new page. I already had created a custom menu with other pages in it (but obviously not the new one), and I had un-clicked the option to automatically add new top-level pages. The new test page still shows up in the header. Presumably that's what would happen to an existing sub-page if I moved it. It looks like only staff can deal with this.

    Thanks for trying to help out. Much appreciated.

  9. I know this probably sounds obvious, but did you remember to save your Custom menu when you were done arranging it? No changes are actually made unless you hit that save button.

  10. Good thought, jennifer. Yes, the custom menu was saved. It's still there when I return to that part of my dashboard. But the selected pages just seem to drag their sup-pages along with them, and the menu-building utility has no "exclude" function.

  11. Did you also select the top navigation in the "theme locations" module at top left and save?

  12. The only options are "Primary menu" and "Secondary Menu." They're not explained. But selecting the "Secondary" choice shuts off the Pages from appearing in the header.

  13. Primary and Secondary menus are available on themes which support 2 custom menus. Most themes which support custom menus so far allow only 1 custom menu.

  14. @sensuouscurmudgeon You need to set the custom menu you created as the primary navigation menu. Go to Appearance -> Menus, look for "Theme Locations", select your custom menu, click Save just below the dropdown.

  15. Oh, you've fixed it. :)
    I don't see the submenus any more in the top navigation on your blog.

  16. Darn! It is fixed. I didn't realize it. It must have been that "Primary Menu" selection. You guys helped me to blunder into it. Thanks to all of you!

Topic Closed

This topic has been closed to new replies.

About this Topic