Need help? Check out our Support site, then


edit post - removes code

  1. How can I keep edit post from removing code upon save?
    For example, it changes the following:

    <img src="http://johnlvs2run.wordpress.com/files/2009/08/watts1.jpg">

    to <img />

    How can I have wp just leave the code the way that I type it.

    The blog I need help with is johnlvs2run.wordpress.com.

  2. Is it "settings > writing > xhtml?

  3. try adding the forward slash at the end, like this:

    <img src="http://johnlvs2run.wordpress.com/files/2009/08/watts1.jpg" />

    Yes, the above code is in XHTML format. That should preserve your code.

  4. devblog, thanks.

    Unchecking xhtml should keep the code from removing my input then?

    I don't mind automatic corrections of code, but removing my text/input is a no no.

  5. Well I had unchecked auto correction of xhtml - and wp just removed all the entire line again! That is very aggravating. I want my text left exactly the way it is.

  6. Unchecking xhtml should keep the code from removing my input then?

    I believe am missing something... I went to "settings > writing > xhtml" and didn't see that setting.

    I agree, even if your code is not valid XHTML, wordpress shouldn't remove it because it is valide HTML. If anything, when the software parses your code, it should correct it, like you said, by adding the forward slash at the end NOT remove your properties.

  7. My bad, you were referring to: "WordPress should correct invalidly nested XHTML automatically"

    No, that's setting is different. That shouldn't correct invalide XTHML markup, but invalidly nested XHTML, which is different.

    Still, me point above stands.

  8. Under "settings > writing > formatting" there is a check box in front of "WordPress should correct invalidly nested XHTML automatically." I unchecked that, but it is still removing my text.

    I see that now that blackslash has been added to the code as you have said, thanks. However on some occasion were I to leave off a digit from the end of a older long post update, it is foreseeable that WP would remove the entire post. It has removed paragraphs before, where I had to redo them from scratch. There most be some way to keep it from doing this, at least I hope so. :)

  9. Okay here we go. I have put the text exactly as above, and WP still removes all the line!

    <img src="http://johnlvs2run.wordpress.com/files/2009/08/watts1.jpg" />

    becomes <img> .................... what the heck???

  10. okay, keep the XHTML checkbox checked, and try the code (with the ending forward slash) again.

    Now, if you have it unchecked, then try using your orignial code (without the forward slash).

    If the problem persists, then is something that needs to be brought to wp's attention and have them fix it.

  11. It has been removing my text both ways, checked and unchecked.

    I'm letting it go for now as have to do something else for awhile. Thanks for your help.

  12. This code I put into my test blog, and it works just fine. All I did was add the alt tag so the search engines and W3C validator would be happy.

    <img src="http://johnlvs2run.wordpress.com/files/2009/08/watts1.jpg" alt="" />

    http://flippintestblog.wordpress.com/2009/08/13/test-for-john/

    This is what was produced by the editor when I did a "from URL" insertion in the visual editor with align none:

    <img class="alignnone" title="John" src="http://johnlvs2run.wordpress.com/files/2009/08/watts1.jpg" alt="" width="376" height="231" />

Topic Closed

This topic has been closed to new replies.

About this Topic