Need help? Check out our Support site, then


embed a google calendar

  1. toddismyname21
    Member

    I followed a tutorial on how to embed a google calendar. Every time I enter it into the html on my page, the text changes and it just puts a link instead of an embedded calendar. What can I do?

    The blog I need help with is civilpittsburgh.wordpress.com.

  2. Hello there,
    Have you returned to the site you got the "tutorial" from? We can't help with tutorials other people may have created.

    As far as I know Google calenders cannot be successfully embedded in wordpress.COM blogs because the code is an iframe code which the software strips out to preserve security. http://en.support.wordpress.com/code/

    This is a link to all forum threads on this subject so you can confirm what I am saying. http://tinyurl.com/68f75sv

    There is an Google Calender RSS workaround we can use here > http://helensnerdyblog.wordpress.com/2007/11/27/how-to-add-a-google-calendar-to-your-wordpresscom-blog-using-the-rss-widget/

  3. I tried that, and it doesn't seem to work anymore, at least Tagul changed something and now makes you fill out all the fields, which renders it unembeddable. Maybe I did it wrong.

  4. @toddismyname21,

    I tried that, and it doesn't seem to work anymore, at least Tagul changed something and now makes you fill out all the fields, which renders it unembeddable.

    That is absolutely not true. You only have to visit the link given by panaghiotisadam to see an example of a Google Calendar embed made possible at Tagul.
    You must be attentive and follow all the steps in the tutorial properly for it to work.

    @raincoaster,
    Yes, you did it wrong. You only had to give me a screenshot that shows your inputs in the necessary fields so that I could figure out what went wrong for you.

  5. Like shown at http://en.support.wordpress.com/google-maps/ wordpress.com has made it possible to add a google MAP to your page. It's pretty simple. Why can't we do the exact same thing for CALENDARS?

  6. I'm sorry but we Volunteers don;t have answers to why don't Staff do this or that questions. You can use this link after Staff return to ask them directly if you wish. http://en.support.wordpress.com/contact/

  7. @sanjidas

    I guess I am having the same problem as raincoaster. I have tried to make a tag cloud using Tagul, but the embed code looks like this:

    src="http://cdn.tagul.com/cloud.swf" type="application/x-shockwave-flash" allowscriptaccess="always" width="100" height="100" flashvars="id=21459@2"

    Linking to the "cloud.swf" source gives just a blue block of nothing, and the tutorial on using Tagul does not adequately explain how to get the flashvars ID inserted into the source URL. So Tagul is embedding properly neither with gigya nor vodpod.

    Any suggestions?

  8. Careful, she'll call you a liar too!

    We do need the URL of your blog in order to help you.

  9. @sanjidas: As rain said, you can't continue with the rest unless you fill in the URL field and click Fetch the Tags.

    @rain: But that doesn't make the thing unembeddable. You just have to add a URL - any URL.

    @freeskooler: Once you get to the embed code, you simply copy the part you pasted above and enclose it in the gigya shortcode:

    [gigya src="http://cdn.tagul.com/cloud.swf" type="application/x-shockwave-flash" allowscriptaccess="always" width="100" height="100" flashvars="id=21459@2" ]

    Change the dimensions and paste into HTML editor. Make sure you've saved the tagul cloud or you'll get an N/A.

  10. Ah, thanks!

  11. You're welcome (and sanjida must be more careful with her absolutes)!

  12. freeskooler,

    I guess I am having the same problem as raincoaster. I have tried to make a tag cloud using Tagul, but the embed code looks like this:
    
    src="http://cdn.tagul.com/cloud.swf" type="application/x-shockwave-flash" allowscriptaccess="always" width="100" height="100" flashvars="id=21459@2"
    
    Linking to the "cloud.swf" source gives just a blue block of nothing, and the tutorial on using Tagul does not adequately explain how to get the flashvars ID inserted into the source URL. So Tagul is embedding properly neither with gigya nor vodpod.

    No, your problem is not the same as rain's. Rain was unable to make the "tag cloud", but you didn't have problem with that. You were having problem embedding it in wordpress.com.

    And that is because the code they give you is Flash.

    and the tutorial on using Tagul does not adequately explain how to get the flashvars ID inserted into the source URL. So Tagul is embedding properly neither with gigya nor vodpod.
    The part where I tell my readers to learn how to change the Flash code for wordpress.com seems inadequate. However, if you follow the link in that post that tells you how to have Flash embeds in wordpress.com you will learn how to embed Flash using vodpod or gigya shortcode. Both methods are explained in vedio tutorials.
    I did say in my post that gigya method is better.

    I couldn't afford to explain the vodpod or gigya method in that post because that post is one of many posts in my blog that deal with embedding different Flash objects in wordpress.com. Explaining how to modify Flash codes in wordpress.com in all such posts is a bit tedious for me.

    @raincoaster,
    Careful, she'll call you a liar too!
    ?

    @panaghiotisadam,
    Thanks for explaining things in a way that readers can understand. You rock!

    and sanjida must be more careful with her absolutes
    Well I have just tested Tagul again and it is behaving just the way it did before.
    It should be remembered that Tagul fetches tags from a url, but that is only one option and not an indispensable one. This "Google Calednar embed" thing for wordpress.com using Tagul is only a workaround and will not work if you add the url, you have to choose the other option, which is text.

  13. Maybe it's behaving just the way it did before, but it's not behaving the way you say it does!

    Yes, you need to add the text you want, but if you leave the URL field blank (as per your screenshot) you can't continue to building the cloud: you get a "Form is incomplete" popup, and if you click OK and scroll up you see a red alert that points to the URL field and says "No tags fetched. Please enter URL or text and click FETCH THE TAGS button." There's also a questionmark next to the URL field that links to this:

    The first thing you should do in order to get your cloud working is to fill the “Core Options”. Choose your cloud name (from 1 to 50 characters) and proceed with providing the source URL.

    So you need to correct your instructions (as well as the last phrase above): both URL and Text are required fields, and Fetch the Tags is a required step.

  14. Mine is working great now, thanks for your help!

  15. @panaghiotisadam,
    I know now why this confusion about url has arisen -Tagul itself says url is required. But it isn't required for this project. Perhaps what Tagul says officially is not applicable here because we are using Tagul the way it was originally meant to be used - as a tag cloud creation tool.

    I face no "Form is incomplete" pop-up if I leave the "url" field as it is. I have tested it again and again. So, I don't want to change my instructions. But I will add a troubleshooting section that will address this confusion.

    I have also discovered that it works for me whether or not I put a (bogus or real) url in the "url" field. I have no idea why no error message pops up in my face.

    @freeskooler,
    It's good to know that it's working for you!

  16. Perhaps what Tagul says officially is not applicable here because we are using Tagul the way it was originally meant to be used - as a tag cloud creation tool.

    That statement misses a crucial "NOT".........

    Perhaps what Tagul says officially is not applicable here because we are NOT using Tagul the way it was originally meant to be used - as a tag cloud creation tool.

  17. @panaghiotisadam,
    I have added a "Things to remember" section in my post which mentions the url problem and I have also linked to this thread hoping the discussion here will help other users.

    Thanks again for your clean and clear explanations.

  18. An update:

    The url problem with Tagul is over. It was probably just a bug during the time Tagul was changing its interface recently. I have updated my tutorial featuring screenshots and instructions related to the new Tagul interface and I have also deleted the "Things to remember" section since it is no longer needed.

    Although Tagul interface has changed (offering more customization options, too), the "url" field is still unnecessary when our job is using Tagul as an iframe-to-Flash converter.

Topic Closed

This topic has been closed to new replies.

About this Topic