Need help? Check out our Support site, then


Embedded Google calendar disappears from emailed post

  1. The support page for Google calendar explains how to embed a calendar, in either a page or a post. This all works as advertised. When the post is emailed, though, an embedded Google calendar disappears without a trace.

    I didn't really expect the calendar to show up in the email version, but I was surprised it wasn't replaced with a link or a note. Maybe this should be documented if it can't be fixed?

    The blog I need help with is t123123.wordpress.com.

  2. Each email client has different settings controlled by their users. Some display images, embeds and videos and some do not.

  3. I know that. I can view the source of the message. I'm asserting that no email client displays any content for the embedded calendar. It's hard to prove that's true. It's easy to prove it's false, by giving an example of one email client that displays an embedded calendar for a WordPress post. I would like to hear of one.

  4. I'll tag this thread for Staff. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  5. It wouldn't surprise me, because we often get complaints that media don't display in emails and so on.

  6. Thanks. I can give a little more info than my grumpy reply about the difficulty of proving a negative. I can tell my email reader to show me the source for the email message, and paste it into a text editor. Then I can use the editor to search for text strings that are displayed in the calendar. Various strings like "Tues" and "Hassselbach" are not found, so the email doesn't seem to contain the contents of the calendar. I can search for "http" and scan the links, but nothing seem to refer to Google. And the email has two pieces, text/plain and text/html, and my reader displays the html version. So it really looks like there's nothing there at all that matches the embedded Google calendar.

  7. Hi there,

    It is rare to find an email client that will support the display of iframe content, as it is a common vector for exploits on the internet.

    Although we convert Google embeds to shortcodes for the purposes of displaying it on your site, your email client will interpret it as an iframe, and strip it from the message.

    You can confirm this by viewing the RSS feed here and searching for "iframe" http://t123123.wordpress.com/feed/

    If you are concerned about having a blank space in your emails, one possible workaround would be to adjust your feed settings (Appearance>Reading) and then be sure to add a Excerpt to your blog posts before publishing.

    Your email will adopt this feed setting and show a bit of teaser text (the excerpt you added) as well as a link to read the full article, where they will be able to see the calendar as expected.

    Hope that helps. Please let me know if you have any further questions.

  8. Thanks for taking the trouble to reply in such detail. I was aware of the More tag but not of Excerpts; I'll have to look into that. I do think the Support documentation would benefit from a topic on distribution of posts via email, with mention of things like this that don't work as the blogger might expect. Your reply would be a good start on one!

  9. Thanks for taking the trouble to reply in such detail. I was aware of the More tag but not of Excerpts

    Sorry, but my instructions above should have also included the step (in Settings>Reading) under "For each article in a feed, show:" to make sure that "Excerpt" it selected.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic