Need help? Check out our Support site, then


Error establishing a database connection

  1. Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

    You get that error when going to my website http://www.dokumentamarble.com . It has been down for about a week now due to this problem. I have contacted my webhost and they have been trying (unsuccessfully) to get help. Any advice or help is welcomed alot. One thing i noticed was that when i looked in my wp-config.php file the passwords and usernames wern't plain, they had _wrdp1' after the usernames. i changed that but to no avail. Suggestions please.

    .dok

  2. Suggestions:

    1) Always read a post labeled Read me first.

    2) Searching for the error first before posting will usually help as well.

    Please head over to http://wordpress.org as that's where you need to be as you're running different software than we are.

    Hope this helps,
    -drmike

  3. Thanks. However I have done both of those already. They did not help me so I posted here.

  4. Here is my wp-config.php if it helps any. The ***** will replace username and password....duh.

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', '*****_wrdp1'); // The name of the database
    define('DB_USER', '*****_wrdp1'); // Your MySQL username
    define('DB_PASSWORD', '*****'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging.

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    Not that I am saying that this is the problem. It could be something else. I dont know, thats why I'm here. Thanks again

    .dok

  5. Please head over to http://wordpress.org as that's where you need to be as you're running different software than we are. Both the read me first post and those threads I pointed you at state that.

    Hope this helps,
    -drmike

  6. http://www.gobi-igloo.com/poems/

    There is an long time urgent need (L.T.U.N.) to get a new dataBASE [wp-config.php] password or find the -lost- original. Apparently I can't change it myself with myphpadmin. Seems like there should be a way out of this problem. Very much appreciate hearing from any of you: [email redacted]

  7. @poembookone
    Please read the posts above your own in this thread. Then please head over to http://wordpress.org as that's where you need to be as you're running different software than we are. Both the read me first post and those threads drmike pointed to above state that.

  8. It's also always best to read a thread before posting in it.

    *sigh*

Topic Closed

This topic has been closed to new replies.

About this Topic