Need help? Check out our Support site, then


Error in exporting/importing multi-encoded blog content

  1. Hi there,

    I've used a wordpress.com hosted blog (http://mhh1422.wordpress.com) for long time and used to add my posts in both English and Arabic to it. Later, I've decided to move to a self-hosted wordpress blog (http://mhh1422en.al-shehab.com).

    I've exported my old blog's content using tools->export and then used the tools->import option in the new blog, but unfortunately, Arabic posts, comments, ... got an worng encoding and appeared as not understood characters, and you can check the two sites: http://mhh1422.wordpress.com (the old) and http://mhh1422en.al-shehab.com (the new) to get the idea.

    I've tried to open the exported XML file in the browser and changed the encoding from windows-1256 into different ones like utf8, windows-1252, windows-1251 but with no result.

    Can anyone help me how to resolve this issue?

    Thanks very much

    The blog I need help with is mhh1422.wordpress.com.

  2. This thread has been flagged for Staff attention. Please be patient while waiting for a response for Staff.

  3. Can you please try switching the encoding on your self-hosted blog to UTF-8, then export it?

  4. @timethief: Thanks a lot. Hope the waiting time overs soon :)

    @macmanx: Sorry I don't get it. Do you mean to change the encoding of self-hosted blog's DB tables or import webpage? Because I need to transfer content of the wordpress hosted blog to self-hosted one not the opposite.

  5. You should be able to change the encoding via Settings -> Reading in your self-hosted blog's Dashboard.

  6. It was already UTF-8, thus, I don't think the problem is in the encoding of the interface because I've already tried to view the exported XML file in different encodings including UTF-8 and all the attempts fail to view Arabic content in the correct form.

    Actually, I've suffered same problem long time ago when I had a database tables in one encoding, an interface in another encoding, and may or may not be input in a third encoding. I think I've to unify the encoding among all of these layers in both blogs or at least have the right encoding while importing which match the same one while exporting, and this can't be done without a help of a wordpress internal programmer and/or wordpress.com db administrator.

  7. That does sound more than likely. I recommend getting in touch with the kind folks over at http://wordpress.org/support/ to see if they have any recommendation for fixing up your encoding site-wide before exporting.

  8. Okay I'll try to.. Thanks for your efforts and help... :)

Topic Closed

This topic has been closed to new replies.

About this Topic