Need help? Check out our Support site, then


Excerpts not working in Splendio

  1. Hello, I'm using the Splendio theme and I want to show only excerpts of the posts in the front page. I have tried this in two different ways:

    1. In the Edit Post page, fill in the "Excerpt" textarea and then in Settings -> Reading mark "For each article in a feed, show -> Summary".

    2. In the Edit Post page, add the "more" tag at some interesting point in the post text, taking care of placing it outside any html tag.

    None of these two options is working and the front pae is displaying the whole content of the posts.

    The blog I need help with is mamboq.wordpress.com.

  2. Since your site is set to private, we volunteers cannot see it. After adding the more tag, are you looking at the front page of the blog after the post is published, or are you using the preview button in the editor, or viewing the single post page? The more tag will only show up on the main posts page.

  3. Thank you for answering.
    I am sorry about not making the blog public but I am still configuring it. :-(

    I am looking at the main posts page after the post is published, the more tag is showing in the editor in Visual mode as a long horizontal line with the word "more" at the end, and also in the html mode as a tag, however, when I go to the front page, the entire post is shown

  4. P.S.
    When I select "View page source" on my browser for the front page, the more tag is there for every post, so something is ignoring it.

    I have checked Front page displays -> A static page -> Home in the Settings -> Reading dialogue, in order to show the "In other news" widget as explained in the Splendio dedicated WP page

  5. If you look at the demo page at http://splendiodemo.wordpress.com/ , the "featured post" slider shows the excerpts, but "latest posts" shows the full post. If the more tag is showing in the posts in latest posts, but then not showing in the post on the the showcase page, then there could be a bug, or for whatever reason, that might be the way the theme is designed.

    Staff monitor this forum so be patient and watch this thread and hopefully they will drop by soon and have a look at this for you.

  6. Ok thank you very much TSP.

    Two minds think better than one: I didn't think about visiting the demo page but now that you mentioned it, it is true that the front page is showing the whole post and not the excerpt or the more tag. I like the Showcase view, but maybe, in that view, the more tag is ignored, as well as the excerpt, so no matter what you do it will always show the entire post. Who knows.

    As you said, lets wait for more feedback! :-)

  7. I would think perhaps this is an oversight. The more tag would make sense for the latest posts section in my opinion. Hopefully they will add support for it, or fix whatever is blocking it.

  8. Ok I have made my blog public, don't pay attention to the content.

    Now that I think it a bit more it may make sense, since the Showcase view is a static page, and so you choose it Settings -> Reading. (That's why it's only showing 1 post)

    So now I have the "Home" page defined as a Showcase and then I made the exercise of selecting the second page, "Posts" as the post page. Now, THIS page should show the excerpts but is again showing the entire post. Also selecting a category or a tag will show the entire posts.

    You may be right, it may be an oversight.

  9. @estherea, @thesacredpath,

    Thanks for bringing the "More" link in Splendio to out attention. I've released a fix now.

    Please let me know if you need further assistance.

  10. Thank you Takashi! Now it's working :)

Topic Closed

This topic has been closed to new replies.

About this Topic