Need help? Check out our Support site, then


Facebook Badge and Like box don't display correctly

  1. childsplaymusic
    Member

    Hi - I have tried to add both a Facebook Badge (using the Text Widget) and a Facebook Like Widget to my blog and site, but neither displays correctly. I'm using the Twenty Eleven theme and my site is hosted on WordPress.com with the address http://childsplaymusic.com.au/

    When I first added the Facebook Badge it displayed correctly - it showed my Page's profile picture, the latest Status update, and the number of Likes. Now it shows none of that - just a blue clickable text saying "Child's Play Music" and "Promote your Page too!"

    I definitely followed the directions for creating it properly in the Help - what's gone wrong? I've tried adding it both to the sidebar of my blog and to the footer of the sites pages - both display incorrectly.

    The Facebook Like Widget is the same problem, except that it never displayed properly in the first place. All I get is a clickable link of the title that I gave the widget ("Like Child's Play Music on Facebook"). There's nothing else - surely there should be a Facebook icon and Like button? There's no documentation on this Widget in the Help at all.

    I'm very new to WP - all help will be much appreciated!

    The blog I need help with is childsplaymusic.com.au.

  2. Hi. The instructions to insert a Facebook Badge are here:
    http://en.support.wordpress.com/facebook-badge/

    To insert a Facebook Like Box, do not use the code provided by Facebook: it will not work here. Instead, go to Appearance > Widgets and drag and drop the Facebook Like Box Widget to the widget area of your choice. Remember that the Like Box only works if you have a Facebook Fan Page. It does not work with personal profiles or groups.

  3. childsplaymusic
    Member

    Thanks for your reply, airodyssey, but I followed those Help instruction for the Facebook Badge to the letter. As I said in my original post, it displayed properly when I first inserted it, but it doesn't now.

    Similarly, that's exactly how I inserted the Facebook Like Box - I dragged and dropped it to the widget area and pasted in the FB Page URL and hit "save". But it doesn't display properly - there is no Like box visible on my site, just a clickable link. Yes, I have a Fan Page - it's not my personal Profile, it's http://www.facebook.com/ChildsPlayMusicPerth.

    Check out my site and you will see what I mean http://childsplaymusic.com.au/blog/ - there should be a Badge and a Like box in the right column, and a Badge in the footer. They shouldn't look like that, surely?

  4. I had a simular problem with the like button. I had to make sure I had the right url. mines http://www.facebook.com/pages/Jeffrey-Reum/350060278344914 what i did was clicked on the facebook button then clicked my paged, then refreshed and i finally got this url instead of the other crazy stuff. It now works after 20mins

  5. @childsplaymusic: I see both your badge and your Like Box perfectly :-)

  6. childsplaymusic
    Member

    @airodyssey - so do I, now! I wonder why? I haven't changed anything at all. I wish I'd taken screenshots.

  7. childsplaymusic
    Member

    And now it's stopped working again! This is bizarre!

  8. I'm seeing both of them just fine on Safari and on Firefox, so this could be an internet or ISP issue. Perhaps an invisible proxy server at your ISP that is not updating properly, or perhaps has an issue and is not pulling those items for some reason.

    Also, it could be a facebook issue since all the elements and such for those two items are being pulled from facebook.

  9. childsplaymusic
    Member

    Thanks - I'm glad you are seeing them, and I appreciate your help. Just checked again, refreshed the page. I still see nothing. I've got screenshots now, but I don't suppose they are much use to anyone.

    I've also realised I should probably have posted this in the Widgets forum.

  10. I'm going to suggest doing the Cookie Dance: log out, clear browser cache and cookies, restart computer. Sometimes things like this happen when you're computer has viewed a lot of media etc.

  11. @childpalysmusic
    Your facebook widget shows just a page, no. of followers and a promoting it something like that. This is more like an ad on your blog possibly because you have not given the proper link to your facebook page. I can see the FB widget working well in your blog where you've given the right link.
    Solution of it is to give the right html link means your admin link. Not the link which is visible to everyone.

  12. @childsplaymusic-I see everything displaying correctly as well, both in the sidebar and in the footer, so as tsp mentioned, it may be an intermittent ISP or Facebook problem. Cheers!

  13. Hi Jennifer!
    Can you (or someone else) see the FB like box in the Fb widget here? http://childsplaymusic.com.au/

  14. @iphonist, childsplaymusic's site is using a static front page with a full width page template, so there is no sidebar there.

    The sidebar appears on the blog at http://childsplaymusic.com.au/blog/ (which for some reason seems to have no posts at the moment) and yes, I do see the Like widget there in the sidebar and the FB Page badge in the footer widget.

  15. But I also can't see the like box in http://childsplaymusic.com.au/. This may be due to the browser I'm using. I'll have a look on it from other browser.

  16. The Like badge is visible only in the sidebar. The sidebar is not displayed on the front page. Hope that was clearer.

Topic Closed

This topic has been closed to new replies.

About this Topic