Need help? Check out our Support site, then


Facebook Images do not correspond to post

  1. So the main issue I am having relates to my images not matching the post I am putting up. When I first started doing my blog it worked perfectly, not whenever I publish a blog, when it sends out the links to my Facebook and Google plus and LinkedIn accounts, it either has no image with it (just a photo of my logo) or it puts a photo from a different photo series all together.

    It is kind of annoying because the images and the posting title are sometimes in no way related therefore making no sense to the viewer. Any help with this issue would be greatly appreciated. I will put a link to the facebook page but I have deleted almost all the posts with the wrong photo, but the ones that just show a logo are still present.

    Facebook page:
    https://www.facebook.com/pages/Jeremy-Deihl-Photography/360364797307803?ref=hl

    p.s. I am also setting featured images for each post because I assumed that was the main issue but that did not help either.

    The blog I need help with is www.jeremydeihl.com.

  2. Hi there,
    This is the WordPress.COM support forum. You need to post to the WordPress.ORG support forum for help with your site because it is not hosted by WordPress.COM.

    WordPress.com and WordPress.org are completely separate and have different logins, features and run different versions of some themes with the same names http://support.wordpress.com/com-vs-org/

    If you don't have a username account at WordPress.ORG click http://wordpress.org/support/ and register one on the top right hand corner of the page that opens, so you can post to the support forums there and receive advice from WordPress.ORG bloggers.

Topic Closed

This topic has been closed to new replies.

About this Topic