Need help? Check out our Support site, then


Facebook like button not in blog's language

  1. I have enabled social buttons in my blog. Facebook's Like button is not shown in the language I have set for my blog, but instead in the language my browser is set to prefer pages. (in Firefox Preferences|Content -> Languages|Choose.

    The button should be "Tykkää" in Finnish, but because my (and many other's) browser wants English pages, it says "Like".

    The Like button is in its own iframe, and the iframe url could be used to set the button language. For example in my blog's post http://mspotilas.wordpress.com/2011/02/25/laakkeet/ the like button's iframe url is:

    http://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fmspotilas.wordpress.com%2F2011%2F02%2F25%2Flaakkeet%2F&layout=button_count&show_faces=false&action=like&colorscheme=light&height=21&width=90

    so no language set -> gets it from browser -> often wrong. But, if the url was:

    http://www.facebook.com/plugins/like.php?locale=fi_FI&href=http%3A%2F%2Fmspotilas.wordpress.com%2F2011%2F02%2F25%2Flaakkeet%2F&layout=button_count&show_faces=false&action=like&colorscheme=light&height=21&width=90

    added locale=fi_FI, then the button reads "Tykkää" as it should.

    (clicking these links only shows the button, and does not click the actual button itself)

    Locale setting would/should be set according to blog's language, in my case fi_FI (Finnish).

    I hope this can be fixed!

    The blog I need help with is mspotilas.wordpress.com.

  2. I'll tag this for staff attention since they will have to address this issue for you. It could be several hours or so before they reply, but hopefully they will soon.

  3. Hi, I have this problem too. I put the iframe code that Facebook gave me in the text widget

    <iframe src="http://www.facebook.com/plugins/likebox.php?href=http%3A%2F%2Fwww.facebook.com%2Fhome.php%23%21%2Fpages%2FAkuntan-Muda%2F201569499854592&width=292&colorscheme=light&show_faces=true&stream=true&header=true&height=427" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:292px; height:427px;" allowTransparency="true"></iframe>

    I clicked save and... the code changed itself into this.

    http://www.facebook.com/plugins/likebox.php?href=http%3A%2F%2Fwww.facebook.com%2Fhome.php%23%21%2Fpages%2FAkuntan-Muda%2F201569499854592&width=292&colorscheme=light&show_faces=true&stream=true&header=true&height=427

    I don't know what's happened but the Like Box didn't show up on my blog. It shows the html instead. -_-"

    Please check it on my blog: http://arierahayu.wordpress.com/

  4. @arierahayu: Actually, your problem is completely different. mspotilas is referring to the Like button appearing below each post and which is an optional feature of WordPress.COM. You are referring to the Like Box which cannot be installed on WordPress.COM:
    http://en.forums.wordpress.com/topic/text-widget-not-accepting-facebook-like-box?replies=40

  5. Hi Guys, from my own experience .com sites (rather than .org) aren't allowed to post these like pages. Instead I have created a badge which is almost as good?!!? I hung out on the forum for a while and that seemed the general consensus!!

  6. @airodyssey: Ow, I'm sorry. Thanks for letting me know. :D

  7. That text comes from Facebook, actually

  8. Yes, it comes from Facebook, and if WordPress asked nicely (with the locale-parameter in the request, see my first post), it would also come in the right language, and not in the "autodetected" (from browser) :)

  9. Ok. We got your ticket in support and a fix has been deployed. However, and due to the fact that Facebook has its own interpretation of what a locale is, for the moment we cannot guarantee 100% accuracy for all WordPress supported locales. We're fine tuning it, though.

  10. Thanks! Seems to work ok.

Topic Closed

This topic has been closed to new replies.

About this Topic