Need help? Check out our Support site, then


Facebook Thumbnail / Picture not displaying to blog post!

  1. Hey guys,

    When trying to post a link to Facebook timeline, the blog image is not displaying. So I looked around a few 'forum threads' for some answers.
    I came across a 'forum' which said to use Facebook' s "Open Graph Object Debugger" to solve the problem which I did.

    However I'm still having problems. When using the debugger, there is a field box titled "Open Graph Warnings That Should Be Fixed".

    With it says...

    Inferred Property: The 'og:url' property should be explicitly provided, even if a value can be inferred from other tags.

    Inferred Property: The 'og:title' property should be explicitly provided, even if a value can be inferred from other tags.

    Inferred Property: The 'og:description' property should be explicitly provided, even if a value can be inferred from other tags.

    I have no idea how to fix this. Need HELP PLEASE!!

  2. Let's start with you posting the URL to your blog please starting with http://

  3. and actual link to blog post is:

    http://maxxedvitality.com/hello-world/#more-1

    By the way, I'm not sure if this makes a difference but I do have a plug-in called "Ultimate Coming Soon Page" as I'm still working on the site. I thought this might be the reason why it wasn't working, but I've tried it with and without and still no thumbnail picture for Facebook timeline posts.

  4. That not a free hosted WordPress.COM blog. We provide support only for free hosted WordPress.COM blogs and you are posting to the wrong support forum. WordPress.com and WordPress.org are completely separate, have different log-ins and run different versions of themes with same names.

    If you don't have a username account at WordPress.ORG click http://wordpress.org/support/ and register one on the top right hand corner of the page that opens, so you can post to the support forums there and receive advice from WordPress.ORG bloggers.

  5. I have noticed two of my recent posts will not display (the image or preview) on Facebook. Why does this happen and how do I fix it? It is not happening consistently.

  6. Mine is doing the same thing. No pictures with my thumbnail.

  7. @http://bookscansavealife.com/
    @annhoover

    I'm sorry but we cannot help with this. The issue is at the other end. We have no control over the images that Facebook chooses to display or when they choose to flush their image caches. We really only send them the URL of the post, and they hunt through that for the excerpt and images to include.

    Please see http://developers.facebook.com/tools/debug
    and http://en.forums.wordpress.com/topic/fb-link-has-no-thumbnails?replies=4#post-936861

    See here too http://en.forums.wordpress.com/topic/pachyderm-theme-image-size-on-reader?replies=9#post-1349306

    See this thread for more tips please > http://en.forums.wordpress.com/topic/wp-post-wont-publish-images-to-fb-but-was-previously?replies=8

Topic Closed

This topic has been closed to new replies.

About this Topic