Need help? Check out our Support site, then


featured image doesn't show up on my blog

  1. When I set a featured image, it didn't show up on my post when I looked at it via "preview". What size does it need to be in order to work? Sometimes it works but sometimes it doesn't. I use theme twenty eleven. TIA

    The blog I need help with is mayahoodblog.com.

  2. Hi there,
    As your are working with Twenty Eleven I recommend clicking the link I just posted and reading a comprehensive article on how the theme is designed to operate.

  3. can you send me the link in here? I couldn't find it on your blog. tnx

  4. It's blue and it's in the comment I posted above http://wpbtips.wordpress.com/2011/05/04/workings-of-duster/

  5. Thanks :)
    So I did use a picture that's 1000 x 288 and it's still not showing up as my feature image. Any idea what else it might be?

  6. Hi,
    Have you also read the theme descition here?

    To get started with the custom Showcase Page Template you need to create a page for it. Choose the Showcase Template under page templates in any page, save it, and assign it as the front page in Settings → Reading. This will change your site from the standard Twenty Eleven blog look to Twenty Eleven’s fancy showcase. You still have you regular blog list at hand for several views, like categories, searches, and tags and you can specify another page to work as your blog if you want to.

    To add posts to the Featured Post section just mark some posts as sticky. That’s all there is to it.

    To have a big featured image you need to use an image that is at least as big as the header image (1000px x 288px). Also, make sure you have a set size for Large image under Settings → Media that allows for such sizes. ... http://theme.wordpress.com/themes/twentyeleven/

  7. edit: descition = description

  8. Thanks for the info. but I'm afraid that this still doesn't solve my problem. On some posts, It will show my featured image, and on others, it won't, and I use large size images. Very frustrating... but tnx for trying.

Topic Closed

This topic has been closed to new replies.

About this Topic