Need help? Check out our Support site, then


Featured image madness

  1. I know this is a popular topic but I'm 100% stuck on this one and hopefully someone will have a solution for this...

    I'm using the Columnist theme, and what I want is a featured image on the main page so there's not just a grey box, but then when you click on the post what I DON'T want is the featured image to then appear AGAIN above the post, as all my posts are images.

    As an example check on the first 3 posts in the list, the first post 'desolate' has no featured image set, yet still shows the preview on the home screen which is what I want as this doesn't show 2 images click you click on the post.

    The second post 'Oxjam Manchester' has no featured image and as expected doesn't show a preview but the image is in the post as normal.

    The third post 'Ants' has a featured image set, and as you can see it does show a preview, but then also shows it twice on the post itself which isn't what I want.

    So from what I can make of this, it's the posts with the picture icon next to them in the list are the ones that recognise it's an image post and don't need a featured image added in order to show a preview in on the blog.

    The problem is, I've checked all the settings on all 3 posts and they're all exactly the same. They were all posted from a laptop and clicking 'add media' to insert the image in to the post, so I don't understand what needs to be done differently to tell WordPress to show the preview without needing a preview image.

    I know you can probably edit the code to remove the featured image on each one and keep it in the preview but I don't want to do that every time I post. There has to be something I'm missing when posting, help!

    The blog I need help with is edduffill.com.

  2. I have screenshots if anyone would like them just let me know. Thought I could upload them to make this simpler. So yeah the main thing is, the first post 'desolate' is how I want them to be, as it's got that little picture icon next to it in on the posts screen in dashboard, but I don't know what to do differently to do that.

    Thanks in advance for the help!

  3. Please consult you theme description. it seems that if you fail to upload a feature image then the gray boxes will display.

    Featured Images
    If you assign a feature image to one of your posts it will display differently depending on which template you are viewing. For instance: on the home page as well as all other pages that display multiple posts, your featured image will appear cropped at 180 pixels wide by 180 pixels tall. In cases where your original uploaded featured image is 610 pixels wide or wider, it will also appear at the very top of single posts and pages. http://theme.wordpress.com/themes/the-columnist/

  4. Thanks for the help, but how does this explain the first post 'desolate' which has no featured image set at all and it's just an image inserted in to the post, but yet still shows a preview of the image on the home screen?

    When I view the list of posts in dashboard, this post has a little picture icon next to it, and all posts of this type show a preview without needing a featured image, but I don't know how to tell wordpress to do this when posting.

  5. Oh oh I've done it! I don't need to find how to get that picture icon, I can add a featured image that's only tiny and it won't appear in the post too.

    Thank you! :)

  6. Yes, you've got it. All featured image dimensions are critical. Best wishes with your blog.

  7. Thanks, you've helped solve something I've had issues with for ages, I've even changed themes before to get around this!

    Does this forum have some sort of kudos system where I can state you've given a great answer?

  8. No there is no kudos system here for acknowledging Volunteers. I do appreciate your kind desire to acknowledge my assistance though.

  9. No worries I appreciate the help and quick reply. If you head to the site you'll see it's all sorted and looking great.

    Thanks again!

  10. how does this explain the first post 'desolate' which has no featured image set at all and it's just an image inserted in to the post, but yet still shows a preview of the image on the home screen?

    A post will display an image on the homepage if you set it as a featured image OR if it's the first image you uploaded from your computer via the Add Media tool of that post.

Topic Closed

This topic has been closed to new replies.

About this Topic