Need help? Check out our Support site, then


featured image not displaying in reader

  1. Hi there, I recently made my 2nd post and set a featured image.

    I have made two posts so far. If you search for 'Armageddon' and 'Melbourne' you should be able to fine my posts. In the reader, my first post displays with a featured image, my 2nd does not, even though I have set the featured image.

    What is going on? (I have tried resetting the featured image but it doesn't seem to do anything)

    The blog I need help with is omaikane.wordpress.com.

  2. I'm still yet to receive any help or advice.

    this is a link to the post which when viewed in 'reader' doesn't have a featured image. Why? I would my post to have featured images please.

    http://omaikane.wordpress.com/2013/03/21/more-armageddon-2012-pictures-gallery-test-post/

  3. Hi, having same problem. Was wondering if it is because the featured image is not in the post itself, just a feature page - contents of post are video. So no option to do a visual edit?
    http://kirstendryburgh.wordpress.com/2013/03/31/vide/

  4. We bloggers have no control over which image is displayed in the Reader.

  5. ok. Thanks

  6. You're welcome.

  7. I find the reader to be incredibly annoying when it comes to displaying images. I just posted a blog with lots of photos that I’m really proud of, and it’s showing up as text only in the reader...(!)

    A few weeks ago I posted a blog with some mediocre images, it seems the reader selected the ‘best’ ones to show and I got 17 likes in the first hour of posting (for some who has about 30 followers, that’s a big deal). It’s just such a lottery...

  8. Hi Omikane and kirstendryburgh,

    I just solved my image display problem, I may have a solution for you both. My most recent post was copied from an original draft. Rather than edit the draft, I copied it, re-wrote it and published the new version. Though I selected a featured image from the image library, none showed in the reader. I later went into that post and clicked on the ‘add media’ button. Then I clicked on ‘media library’. There is a drop down menu that gives you the option to view pictures ‘uploaded to this post’. When I clicked on that it showed zero images because although I had images in my post, they had all been copied across from the original draft and I hadn’t uploaded any new images. (This would also happen if you just used images that were already in the media library).

    This is where the reader takes your images from (I’m guessing). If this is empty, you’ll need to upload the image again while in the edit mode for THAT post. You don’t need to insert it in your post. Just click out once you’ve uploaded it and click, ‘update’. And voila, it will appear in the reader.

    Well, that’s what happened for me. I re-uploaded the featured image and suddenly it appeared in the reader. Sadly, I realised a bit late, so anyone who saw my post in the reader during the first few hours would have just seen text.

    So, I actually believe you can control what images appear in the reader.

Topic Closed

This topic has been closed to new replies.

About this Topic