Need help? Check out our Support site, then


Featured Image Problems in Structure Theme

  1. jerryjacques1980
    Member

    I have tried to use a featured image in the structure theme...i have gone through the proper steps...selected the image and clicked use as feature. The image does not appear on the front page. Instead there is a white area where it should be. It also does not appear when you go into the post itself.

    In case you are wondering:
    1. Yes I downloaded the image from my computer.
    2. Yes it was big enough
    3. Yes I also selected to have the image display on the post in the theme option.

    This is a recent problem, seeing that I didn't have this issue in the past.

    The blog I need help with is rethor.wordpress.com.

  2. a) Link to the blog in question please. The one linked to your username is using 2011, not Structure.
    b) You need to correct your username link: you've added the http part twice.
    c) In the meantime read these (because most likely you're wrong re no.2):
    http://wpbtips.wordpress.com/2010/05/01/introduction-to-structure/
    http://wpbtips.wordpress.com/2011/10/21/on-the-recent-featured-image-issues/

  3. jerryjacques1980
    Member

  4. The image you've set to your latest post is this:
    http://rethor.files.wordpress.com/2012/02/cardinals1.jpg
    Dimensions 512x341: as suspected, not big enough! Check the posts I linked to.

  5. Hello there,
    When it comes to featured images they must be the exact dimensions specified by the theme. You will find those in the articles that justpi linked to above.
    You can also consult these troubleshooting images tips.

  6. jerryjacques1980
    Member

    The problem is resolved. It was a size issue. Apparently the size of the pictures weren't big enough. I had to crank it up using the scale.

  7. Hi, I'm new to the structure theme. I have been trying to get a image to occupy the grey space. I'm blogging online, using the free version. May I know how I can get something or anything to appear!

    Link to my blog address:
    http://emoturtlet.wordpress.com/

    Also, I would like to have thumbnails attached to each of my posts. Is it possible? Please advice! Many thanks in advance. :)

  8. Hi Juspi,
    I've visited many links which brings me to the one you have provided but it is not helpful. I am looking for a more detailed guide as it is really impossible for me to upload any pictures no matter what I do.. I'm kind of helpless.

  9. I don't see a featured image attached to your post but I do see a regular image attached. What sort of error are you running into when you try and upload your featured images?

  10. The regular image on the right is actually from the gravatar widget. I can't seem to get the featured image in the grey box. I've uploaded the picture. It is of a bigger size than the one stated but I don't mind if it gets cropped. upon saving changes, the featured image does not show.

  11. "Upon saving changes"
    If you mean you pres a button that literally says "Save Changes", then you're on the wrong dashboard screen.
    To set a featured image to a post, you edit the post, click the Add Media button, upload the image from your computer (or select it from Media Library, if it's already uploaded), then click "Use as featured image" instead of "Insert into post".

    Also, are you seeing the Featured Image module while on the post editor screen? If not, click Screen Options (top right) and activate it. When you have successfully set a featured image to a post, the Featured Image module will display that image.

  12. i'm in the post editor screen and i click "use as featured image". still there wasn't any image appearing in the grey box. yes. i saw the featured image module on the right hand side while on the post editor screen. I had activated the "set featured image" module using the screen options(top right) no, the featured image module did not display the image.

  13. If the Featured Image module isn't displaying an image, then you haven't set one. What exactly are you trying, step by step? Are you trying to insert the image via URL, perhaps, instead of what I explained above? Images hosted elsewhere won't work: a featured image needs to be uploaded from your computer to your blog.

  14. hmm.. that's the part i do not get. I uploaded the picture into the blog. that's why as I mentioned, i'm totally clueless on what I have done incorrectly...

  15. a) Go to Media > Library (dashboard sidebar) and check if the image is there.
    b) Describe exactly what you tried to do, step by step.

  16. 1. Clicked on "Set Featured Image"
    2.Clicked on Media Library. Image uploaded. Clicked "Show"
    3. Dimensions: 800 x 449. (is this ok? I don't mind the pic being cropped)
    4. Under size: Full size selected 600 x 359. Right under the selection of sizes, clicked on the option "use as featured image" then saving... came on. followed by done.
    5. i went on to save all changes. i closed the box.
    6 in the module set featured image i can see the image i set. on the homepage, there's still nothing. sigh...

  17. 1-3 ok.
    4-5 irrelevant: all the options except "use as featured image" are for images you insert in the post, not for featured images.
    Last step is close the box and click Update (post).

  18. 54africanvoices
    Member

    hi guys

    i had activated the theme and initiallly there was no featured story at the home page, then suddenly there is?

    how do i take it off
    i cant seem to get the right size pic....
    or alternatively how do i completely remove all association of my blog to that theme. because i think after pressing save on the appearance-> theme options only then does the grey pic appear

  19. The blog linked to your username is using Under the Influence, and before that it was using Manifest. If you're talking about a different blog, we need its URL.

  20. i clicked on the a new post to get to the post editor screen. After carrying out 1-3, i will need to save changes right? after saving changes, or even if i simply close the box, there is no option to update. only to publish. if i were to get to the post editor screen using an existing post, after i carried out the steps and update the post, there is still nothing featured in the grey box.

  21. Naturally "Update" applies to already published posts; for a new post it'll be "Publish". Try again: edit your latest published post, set a featured image etc., then go to Media > Library (dashboard sidebar), find the image you used, hover over it, click Edit, copy the file URL, paste it here so we can check the image.

  22. http://emoturtlet.wordpress.com/wp-admin/media.php?attachment_id=603&action=edit

    sorry for the late reply. here u go. Thanks so much

  23. We don't have access to your dashboard: as I already wrote, you need to copypaste the file URL, not the URL that shows up in the address bar of the browser.

  24. fairviewfashion
    Member

    Hi. I can't get my featured image to work in the Structure theme either. I understand that for Structure the rules are:

    Small: 440 x 240 on the home page for featured posts
    Medium: 620 x 380 on the home page for latest feature post
    Large: 640 x 392 on single posts

    When I try to scale an image it changes both sizes so 300 becomes 300x300. How do I get it to just change one side so I can get it right?

  25. @emoturtlet: No that's not correct either. Don't you see it says "wp-admin" in the URL? Only you, the administrator of your blog, can access URLs of your dashboard screens. The file URL of an image is the URL that shows up in the file URL field when you click Media > Library > Edit.

    @fairviewfashion: If you're referring to Settings > Media, those options have nothing to do with featured images. All the options of the window that pops up when you're about to insert an image apply to inserting a regular image in a post, not to setting a featured image. A featured image won't show up unless the original file you upload is in the right pixel dimensions or larger. For Structure see here:
    http://wpbtips.wordpress.com/2010/05/01/introduction-to-structure/
    http://wpbtips.wordpress.com/2010/08/23/featured-images/
    http://wpbtips.wordpress.com/2011/10/21/on-the-recent-featured-image-issues/

  26. Yup, that's ok, and the image is fine: large enough, and not corrupt or anything.

    So I've run out of answers: if that's the image you've tried to use, and if you can see it in the Featured Image module of the post editor when you edit the post "Examinations Out", then it should be showing on your homepage.

Topic Closed

This topic has been closed to new replies.

About this Topic