Need help? Check out our Support site, then


Featuring Posts in a Slider

  1. leffelrich2013
    Member

    Hi there,

    I realize a lot of people have asked about this, but I can't for the life of me figure out how to get pictures to appear in a slider like they do on the demo.

    I see these instructions on the Forever Theme Showcase:
    "Featuring posts in a slider on your home page is easy. You just need sticky posts with Featured Images. Every sticky post you have (up to 10) that has a Featured Image (at least 888 pixels wide) attached will show up there. Easy!"

    I have posted four posts with featured pictures that have a width of 888 pixels and I have made those posts sticky posts, but no slider is showing up on my homepage. What am I doing wrong? My website, now in its very early stages, is http://leffelrich2013.com/

    Thanks!

    The blog I need help with is leffelrich2013.com.

  2. I think you are not clear on the differences between Pages which are for static content that rarely changes and sit outside the blog structure and Posts. Only Posts can appear in the slider. http://en.support.wordpress.com/post-vs-page/

  3. leffelrich2013
    Member

    I think maybe there is a problem with my understanding of pages vs. posts, but as far as I can tell, the pictures I added were in posts. They're appearing in my archives (http://leffelrich2013.com/2012/10/), but nothing is showing up on my homepage.

  4. Hi again,
    Did you upload the images from your computer into the Medial Library ie. onto WordPress.com servers? If you did not do that then they will not display.

  5. leffelrich2013
    Member

    Hi again,

    The files were showing up on the server but the picture itself was broken, so I re-uploaded the pictures onto the media library. Now that I've done that, they're showing up in the posts (http://leffelrich2013.com/2012/10/) but not on the homepage (http://leffelrich2013.com/).

    Is there anything I need to do to my homepage to make it post-friendly? Also, should I click "Show four of your latest posts in columns on your home page" or not? I've tried this both with the box clicked and without, and it doesn't make a difference for the slider at least.

    Thanks for your help. Hopefully I can clear this up soon!

  6. Forever has post formats for > Gallery, Image, Status, Quote
    I believe you need to edit the posts and deselect the post format you have assigned to them, then select "standard".
    http://en.support.wordpress.com/posts/edit-posts-screen/

  7. leffelrich2013
    Member

    Hmm, they are all already in the standard format.

    Status: Published
    Visibility: Public, Sticky
    Format: Standard

    Does it need to be categorized at all? Does the photo need to appear in the post as well?

  8. And these are the settings for my homepage:

    Status: Published
    Visibility: Public
    Parent: (no parent)
    Template: Default Template
    Order: 0
    Featured Image: none

    The homepage is definitely a page and not a post, but I don't know what it should be.

  9. leffelrich2013
    Member

    Alright, I fixed the homepage so it's for posting instead of being a page and... the slider works!

    Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic