Need help? Check out our Support site, then


Feed count won't update

  1. Hi, I've tried several times over the past few weeks to change my feed count. I update it under Settings >> Reading. I change the number of syndicated posts to show, say from 5 to 7. Or 7 to 2. And then Save it. And it just doesn't ever change it. Can you help?
    Blog is http://saraahlouisek.com

    Thank you so much.

    The blog I need help with is sarahlouisek.com.

  2. Oh -- and I've tried clearing the Cookies, and the Cache. But still, no update to the number of items in my feed.

  3. Hi there,
    I have checked both of my blogs and what I see is 7 posts in the RSS Feed regardless of the settings here > Settings > Reading
    I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.

  4. Hi Timethief,
    It looks like I am subscribed, so I will watch for a Staff response. I appreciate your help, thank you.

  5. You're welcome.

  6. @sarahlouisek: Your feed settings are set to 5 currently and this is a screenshot when I previewed your feed in the Netvibes RSS reader: http://d.pr/i/MCsg

    As you can see, there are only 5 of your most recent public posts being shown. If you use a feed reader that auto-loads more items from a URL rather than the feed itself - like Google Reader - then there's no way to limit that.

    You do have it set correctly for a traditional RSS reader - so if you want to change it to 2, update it in the Settings -> Reading from your site's dashboard.

    I hope that clarified things!

  7. Hi,

    Thanks for the link. I see what you mean in Netvibes.

    But I am still a bit confused. When I look at http://sarahlouisek.com/feed/, there are 12 public posts shown. If I set my number to 5 feed settings, it should show 5 posts there too, rather than 12 posts. That's what I gather from the info below, which is from the WordPress site under "Support." Can you help me make sense of the discrepancy between what you wrote and what the site claims?

    Thanks!

    FROM WORDPRESS SITE
    FEEDS
    Every WordPress.com blog has multiple feeds. The main content feed can be accessed by adding /feed/ to your blog’s URL.
    As an example, here is the feed of the official WordPress.com blog:
http://en.blog.wordpress.com/feed/

    SUPPORT
    Settings >> Reading Settings
    Syndication feeds show the most recent lets you set how many blog posts will be sent out at once via your RSS feed (located at http://your-domain.wordpress.com/feed/).

  8. You're seeing more than five is because you are logged in and seeing your private posts included in the feed.

    Log out of your WordPress.com site and view your feed again at http://sarahlouisek.com/feed/ - and you will see that you only have five items in that feed.

    I hope that clarifies things! :)

  9. Hmmm. Well, later today I tried changing it to 1 post. And my feed showed 1 post whether or not I was logged in. Then I changed it to 4 posts. And it still shows 1 post whether I am logged in or out. So something funny is still happening. I wish it wasn't , but I don't want to consider this item resolved yet until things are working properly.

  10. Can you please try clearing out your cache and cookies and see if that helps? http://en.support.wordpress.com/browser-issues/#clear-your-cache-and-cookies

    If your browser is caching old information, you won't see any changes that you've made.

    I just checked your public feed again and I show 4 posts. So the changes you're making are working, but your browser might not be showing the most up-to-date version and clearing the cache will help.

  11. Ok, I cleared the cache and cookies. Now I show 1 post -- even though I just reset my reading setting to 5 feed posts. Hmmm, this is so strange.
    Can you tell me if you now show 5 posts in my feed? If so, there may be something strange happening with my Safari browser. Perhaps it is not getting cleaned out and reset, even when I clear it out manually.
    Thank you for your assistance, I appreciate it.

  12. Yes, I show that your feed is listing your 5 most recent posts. I hope that eases your mind that you did set it up properly. :)

    Let us know if we can help with anything else!

  13. Fabulous, thank you. Then all is well. I appreciate your help resolving this!

Topic Closed

This topic has been closed to new replies.

About this Topic