Need help? Check out our Support site, then


Feedburner Feed not displaying photo with each new entry

  1. Most everyone I know who has a feedburner RSS feed on their blog has a photo beneath each new entry from that entry. Mine does not, just all text (click on the Subscribe by Feed on my blog and you'll see what I mean). How can I get a photo to show with each new entry? My url is http://lisamichele.wordpress.com

    The blog I need help with is lisamichele.wordpress.com.

  2. Anyone out there? :)

  3. First off you have your feed here set to "summary" which means it will not have the images. You can see that by looking at your feed coming out of wordpress: http://lisamichele.wordpress.com/feed/ . Go to settings > reading and change your syndication feed to show "full" posts.

    If that does not fix it, look at the settings for your feed over at feedburner. As I understand it you can set it to display or not display images, and also to show the full posts or summaries.

  4. By the way, it can take up to 15 minutes or so for the feed to change to full coming out of wordpress, and it may actually take Feedburner 24 hours to catch the changes.

  5. First off you have your feed here set to "summary" which means it will not have the images. You can see that by looking at your feed coming out of wordpress:

    Not necessarily true.

    My feeds are "full" but are still just snippets comming out of wordpress:
    http://husdal.com/feed/

    My Feedburner feed is full, though
    http://feeds2.feedburner.com/husdalcom

    There's no way to tell by looking at the feed from wordpress. Apparently the feed from wordpress only shows post summaries, even though it may syndicate full posts...weird.

  6. Thanks, guys, Thing is, I cannot find anything on Feedburner that gives you the option to display or not display images. Any idea where that might be found?

  7. Also, husdal, how did you get your feedburner feed set to full so it displays your images?

  8. If you are syndicating full feeds in Settings > Reading in wordpress and you have inactived Optimize > Summary Burner in Feedburner and you are directing Feedburner to read http://lisamichele.wordpress.com/feed/ NOT http://lisamichele.wordpress.com/feed/atom/ then your post iamges should come out. I don't remember there being a setting in Feedburner for turning on/off images.

  9. How can I direct Feedburner to http://lisamichele.wordpress.com/feed instead of http://lisamichele.wordpress.com/feed/atom/?? BTW, thanks for taking the time, thus far :)

  10. The summary Burner is not active, and this is what it says under my Optimize section

    You should not change "Original Feed" unless you move your original feed to a new domain or a new location on your existing server. Also, changing "Feed Address" will require you to update your feed subscribers with your new address; the previous feed address will no longer work.

    Feed Title: Parsley, Sage, Desserts and Line Drives
    Original Feed: http://lisamichele.wordpress.com/feed/ (feed published on your site)
    Feed Address: http://feeds2.feedburner.com/wordpress/PEjE (Your FeedBurner feed)

  11. You enter the URL of your feed in 'Edit Feed Details' above the Analyze-Optimize-etc tabs.

    Anyway, seems to be working fine now.

    Since you have a lot of photos in your posts and thus, in your feed, I suggest you go to Settings > Reading in WordPress and lower the numner in 'Syndication feeds show the most recent ## posts'.

  12. yAAY..FINALLY. SO, i SHOULD CHANGE IT BACK TO SUMMARY INSTEAD OF FULL TEXT AND THE NUMBER IN SYNDICATION FEEDS? sORRY, MY CAPS GOT STUCK AND i CAN'T PULL IT OUT..LOL

  13. No, keep full text, but make it ,say, 'Syndication feeds show the most recent <b>3</b> posts'. Just my suggestion.

  14. No, keep full text, but make it ,say, 'Syndication feeds show the most recent 3 posts'. Just my suggestion.

  15. Thank you so much for all of your help! However, it's still displaying the whole posts with ALL the photos..yikes! Hmmm..what to do..what to do..??? LOL

  16. OK, so now I have the opposite problem, not only is my whole post showing up under the feed, but ALL the photos!! I definitely don't want this and tried switching back to summary in WP, but then all photos disappeared! Any advice as to what I can do in 'this' case? I just want a brief summary and one photo like most have *sigh*

  17. Who is "most"? Can you give an example? As I see it there's only two options with Feedburner, summary without images or full post with all images.

  18. Most as in felow food bloggers who use feedburner. When I click theirs on, it's a brief summary with one photo, as sort of a tease. I don't people reading my full entries in reader. I want them to come read it in my blog :)

  19. Wow..sorry for the above typos..I've been up all night.

  20. Most as in felow food bloggers who use feedburner If you could guide me to one such blog, I could go and have look and maybe find out how they are doing it. Thanks.

  21. husdal, the reason your WordPress feed only shows snippets is that you're using Read More on every post. Your feeds are automatically truncated in that case. If that's not what you want, then you need to stop using Read More.

  22. @raincoaster
    I want the Read More, and I'm fine with my feed and I'm not sure you're right. If you compare to Lisa above, her WordPress feed also only shows snippets, and she is NOT using Read More, and her WordPress feed must be set to full since her Feedburner feed shows full posts. Simple deduction. If am wrong, I stand corrected.

  23. Here's one, husdal

    http://therepressedpastrychef.com/

    Also, how do I set my entries to 'read more', so my page isn't clogged up?

  24. Read More, see here: http://support.wordpress.com/splitting-content/more-tag/

    As to the feed you mentioned, if you study the feed, it says 'Feed enhanced by Better Feed from Ozh' under it. That's a plugin for self-hosted WordPress blogs. We cannot do that on wordpress.com blogs. So the basic answer is, no, you cannot have a feed like that. And adding Read More to your posts will not change that, but it will make your front page look nicer (I think so) and certainly load faster because there are less photos to load.

  25. @raincoaster

    I do stand slightly corrected. Forgive me my ignorance, but I had no idea my WordPress feed was displaying so differently from browser to browser:

    FF - only snippets, no images
    Chrome - raw HTML as text
    Opera - raw HTML as text
    IE - full post with images
    Safari - full post with images

    I use FF mostly, hence my annoyance with seeing only snippets. In any case, Read More has no influence on how the feed displays.

  26. Thank you, husdal. I suppose the whole post with all images is what I have to acceopt until I host my own WP blog an can upload scripts.

    That said, The Read more worked, and after fixing all of my posts with it, I decided I preferred it showing more as the 'read more' was very small, and some might not pick up on it. so I changed it back and made sure to set 'reading' to only 3 posts per page so the site wouldn't take as long to load :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.