Need help? Check out our Support site, then


Fixing line breaks in the summary when displayed on the front page Sunspot Theme

  1. Sure hope I explainit correctly. I am using Sunspot theme and I love it. However, when I generate a post and view it from the 'home' page, the line breaks are gone.. all the test runs together and it is driving me nuts. Is there anyway to fix this? I have tried putting in
    and <p> and nada... thanks.

  2. The excerpts displayed on the front page are supplied by the template and we cannot edit either templates or themes. > Themes Options provides two choices you can make for front page display:
    Single Column, with full post content
    Two Columns, with excerpts and featured images

  3. @cc101classes: That's standard behavior in all themes that display auto excerpts on the main page: all HTML is stripped out, so you get plain text only - no bold or italics, no line or paragraph breaks, no links, no images etc. To change this you need to create custom excerpts: add content in the Excerpt module of the post editor and use the right coding to format it.
    If you're not seeing the Excerpt module while on the post editor screen, click Screen Options (top right) to enable it.

  4. If you choose "Two Columns, with excerpts and featured images" you can use a workaround to overide the excerpt function. The theme is behaving exactly the way it is designed to behave, which is excerpts only on the front page of the blog but it does have an active excerpt box below the post editor, so you can control the length of the excerpt displayed. This is the workaround you can use to override excerpt display on the front page.

    You compose your whole post first and before you publish it you switch to the HTML (Text) editor, copy the code, paste it into the Excerpt box, and publish the post. http://en.support.wordpress.com/splitting-content/excerpts/#creating-excerpts This will have to be done on every post.

  5. thank you all... how can i delete this thread?

  6. ty timetheif for flagging this thread for me *hug*

  7. richardfollette
    Member

    Hello, All:

    I am using Theme 2011, and want to simply Post, utilizing the Title as 'link' (to post), while using the Excerpt function; what this has done, is to deprive the 'post page' of a workable Title Link - in fact, the Title is never listed if I have used Excerpt for the 'read more' feature link.

    How can I show both the Title (as link), and maintain my secondary page at the same time?

  8. @croppycat
    You're weclome. :)

  9. @richardfollette
    This thread is focused on the Sunspot theme. To create your own thread click this link > http://en.forums.wordpress.com/?new=1

  10. P.S. Also read this before you create your own thread > http://en.support.wordpress.com/posts/post-formats/
    You are creating "Asides" not Standard posts. Hence, your problem

  11. richardfollette
    Member

    Thanks, TT.

  12. You're welcome. :)

Topic Closed

This topic has been closed to new replies.

About this Topic