Need help? Check out our Support site, then


Follow Button too wide

  1. I just noticed that the WordPress Follow button is a bit too wide for the widget area. The final letter seems slightly visible but is not in the blue box. Is there a fix?
    I moved the widget area down slightly using the relative position setting because it was getting chopped off on my Android phone display. But I don't think this affected the width problem. Thanks.

    The blog I need help with is policestateproject.wordpress.com.

  2. Hello!

    I've tested your site in three different browsers here, and the Follow button is looking great!

    https://cloudup.com/cfe3kdwoRaY

    Can you tell me what web browser and version you are using? Perhaps there is an upgrade available for your browser?

    - Joe

  3. I had Firefox 26.0. Just updated to 27.0 but it didn't change this problem. Here's a screenshot: http://thepolicestateproject.com/?attachment_id=348
    Based on your experience, I looked at the site in Explorer. The twitter button was perfect there, but the facebook widget was a blank black box, just like I'm getting on my phone.

  4. Hello,

    The facebook widget is empty, because the page that it's referencing no longer exists.

    https://www.facebook.com/pages/The-Police-State-Project/

    Let me know if you have any other questions. :) - Joe

  5. @johnchasnoff, in Firefox, reset your zoom level and see if that doesn't take care of the follow button issue (View > Zoom > Reset).

  6. Joe--thanks. The facebook page wasn't published yet; when I published it, the problem resolved.

    The Sacred Path--Thanks for the suggestion. Resetting didn't help. Zooming in made it worse, but the reset position was where I already was, and seems the optimal setting--zooming out further did not further reveal the button. Is this a glitch for everyone in firefox?

  7. I'm seeing your site just fine like @jboydston in Firefox 26.0 (27 hasn't hit me yet), Safari 7.0.1 and Google Chrome 32.0.1700.107, so I'm not sure why you are seeing it this way in Firefox. I was going to run it through Browsershots.org for FF 26 and 27 on Windows to see if the problem was a Windows only issue, but you have changed it to just "Follow".

  8. I made my site title all caps, and it made the follow button problem worse. That's why I switched it to just "follow." But I put it back so you could run those tests. Thanks.
    PS: The problem is even worse on my android phone: the follow button is missing its top half. Looks fine on my wife's iphone. I might just have to delete the button altogether. But I'm interested in what you might discover. I'll leave it as is till I hear from you.

  9. This is kind of a complex thing, after digging into it further, and I'm going to file a bug report on it. Long text should wrap onto two lines, I think, and it isn't doing it.

  10. The follow button widget title follows the settings for the site title, and when you set the site title to all caps, that was carried over into the follow button widget. I can find no way to reverse that on the follow button widget with CSS. I'll let you know as soon as I hear something back on this.

  11. Thanks for all your follow through. I'm happy (actually prefer) to have title in Follow Button be all caps. If it would wrap around as you say it should, I'd be happy. Does that version still show fine in your browsers?

  12. The non-caps version just takes a bit narrower browser window to get to the cutoff point. I'm not sure how the developers will address it, but it has been reported and is on their desk, so to speak. I can't give an estimate on how quickly it will get resolved, but we will let you know when it is.

  13. Thanks. I'll wait to hear. And in the meantime do you have a sense of how many people this affects?

  14. It's probably affecting people who have very long site titles and who also use the follow button with the "Show blog name" setting checked in the widget settings. So it's hard to say exactly how many.

    I'm not sure how long it will take before someone will have a chance to review it again, so I thought I'd post some possible workarounds. One is to uncheck the "Show blog name" setting in the widget. Another could be to make the sidebar a little wider in the Twenty Eleven theme. It will help make it so the button doesn't get cut off for wide browser widths such as on laptops and large displays. It's not perfect, but it might work for you as a temporary workaround. Here is the CSS in case you'd like to try it out:

    #secondary {
    	margin-right: 5.6%;
    	width: 20.8%;
    }
  15. It has been quite a while since this thread was active, so I am going to mark it as resolved. If you have further questions or problems, please feel free to start a new thread.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic