Need help? Check out our Support site, then


fond changes haphazardly

  1. alltagspiritualitaet
    Member

    Help! The fond within my posts changes randomly. I have tried to clear it up with the rubber button - but succesless. Therefore I 've changed my theme now it looks weird than before because some of the old posts kept the old fond and other have the new???? I would be really greatful to find a solution :-)

    The blog I need help with is alltagspiritualitaet.wordpress.com.

  2. 1) Never copy paste from Word or elsewhere on the web. It adds these junk tags to your content that cause this. The problem gets worse over time.

    2) Go to Settings->Writing and selecct "Wordpress should correct invalidly nested XHTML" and save.

    3) go to your dashboard Posts page, select all visible posts, usually 20, set them to Private, then set them back to public. This forces the change in 2) to take effect on them.

    4) If you don't like writing the post live in the post window, use Windows Live Writer or Ecto. They are specifically designed to be offline blog editors, and work much like Word only you can properly format for your theme, you can add tags and categories, and you can embed media.

  3. alltagspiritualitaet
    Member

    Dear Raincoaster, thank you very much for your answer!
    I',m really greatful. Now I've got many things to try....
    I'll come back and give report after I worked through... :-) Greetings Tulla

  4. @rain: Your diagnosis (#1) is correct, but ##2-3 won't have any effect in such cases. The auto-correct option adds missing closing or opening tags: it cannot remove correctly formed code that simply shouldn't be there. The only thing the OP can do is edit each post and either a) switch the editor to Text and remove all the opening and closing span tags for font and size, or b) select all in the Visual editor, click the "remove formatting" tool, then use the other tools to add back whatever formatting was intentional (bold, italics etc).

    @alltagspiritualitaet: Never copypaste from other sources into the Visual editor. When you need to paste, paste into the Text editor, so that only the text and no extra code will be added.

  5. Well, I primarily suggest 2 so that things don't get worse as time goes on. WHY is it not the default?

  6. WHY is it not the default?

    Ah yes, we've talked about this in the past too: you don't see why, I don't see why, nobody sees why...
    WP asked for feedback on the new dashboard design. What I sent them was precisely this. I pointed out that year in year out we see countless users complain about sidebar at the bottom and such, asked them "do you enjoy this?", and told them that the auto-correct option should be on by default, not off.

  7. Quoting from this post of mine:
    http://wpbtips.wordpress.com/2012/05/19/sidebar-at-the-bottom-and-related-issues/
    "None of us experienced volunteers can fathom why WP insists on keeping the default to off instead of on: if you are an average user, you’ll probably not notice the option, nor understand what it means if you happen to notice it; and if you are an average user, you probably don’t know what causes those layout issues either, so you won’t even look for such an option."

  8. alltagspiritualitaet
    Member

    @justpi Thank you very much for your answer. I' lll try what you suggested. I'm one of these plain users :-) What are open tags? I found a button "close open tags" What does that mean? I've checked the html and cleared up some tokens which make bold but that doesn't affect the fond???

  9. You're welcome.

    To understand about open tags and the rest, you can study this tutorial of mine:
    http://wpbtips.wordpress.com/2012/02/05/introduction-to-html-for-wordpress-com-users/

    If you edit one of your older posts and switch the editor to Text (=code), you'll see that it's full of tags like these (plus the corresponding closing tags):

    <span style="font-family:Times New Roman;font-size:medium;">
    <span style="font-size:large;">
    <span style="font-size:medium;">
    <span style="font-family:Times New Roman;">

    The font changes because of these tags, and these tags were added because of the copypasting into the Visual editor. They are too many to delete manually, so you should follow my suggestion "b" above.

  10. alltagspiritualitaet
    Member

    Thank you VERY much for your support! I've started to clear up the tags in the text and it's really interesting to see how many trash was imported!
    @ justipi: I'm so glad that you wrote in your article that you also started bare of knowledge, that was very encouraging
    Here some nerd fun for you :-)
    http://tuttisworld.wordpress.com/2013/03/23/how-to-shock-a-nerd/
    or me and my not soo very well working computer
    http://tuttisworld.wordpress.com/2013/04/09/tuttisophie-7/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.