Need help? Check out our Support site, then


Forcing a future post to publish

  1. This seems like something someone would have asked already, but search isn't bringing it up. I set the post's time for the year 3000 so I wouldn't accidentally publish it while editing. I set it back to a time a few minutes in the past, but the schedule button didn't change to publish.

    Should I schedule it for a few minutes in the future and wait for it to publish, or is there something I'm missing?

    The blog I need help with is mkronline.wordpress.com.

  2. press the "Cancel" button on under "publish immediately" and it should return post publishing to the normal format.

    After that just press the publish button when you ready .

    doing that should be easier than trying to reset the time to a couple minutes before or after.

  3. Try clearing your cache and cookies:
    http://en.support.wordpress.com/browser-issues/

  4. That's not helping with this post, unfortunately. It's already set. And despite setting it to the past, it won't publish. Is this a bug, or is wp.com's cron pass not as frequent as on self-hosted blogs?

  5. Please update the link to your username or provide it when asking a question:
    http://mkrwp.wordpress.com/

    So, after finding your blog, it appears not to be a browser issue.
    Continuing to think along the line of fixing the simplest things first:
    Are you sure your typing when resetting the date is accurate? (2011, not some other year?)

  6. That's not the blog I set when I made this thread. It's http://mkronline.wordpress.com/. I've checked all the obvious stuff, and everything is set correctly. I've run into scheduled posts that won't publish at the scheduled time on self-hosted WP installs, but I always fixed it by editing and updating the post.

    I think I'm just going to trash the post and recreate it with the same content.

  7. What is the TITLE of the post? It's possible it published and for cache reasons, you can't see it but we can.

Topic Closed

This topic has been closed to new replies.

About this Topic