Need help? Check out our Support site, then


Forever front page

  1. Hello,
    I've re-read all the Forever forums and related documents, but I'm still having trouble with the front page. I think I want a static front page. I want this to be a website, not a blog. So I made two pages, one for the front which I titled "Welcome" and shows up in the menu as "Home," and one for posts which I titled "Offerings." On the Offerings page the sticky post featured images appear on the slider. That's good!, but I'd like it to be the front page. How would I do this? Also, when I view this Offerings page, below the slider it says, "A great WordPress.com site." And below that it says, "Nothing Found." Like this page isn't quite valid. Not sure why or how to fix. Please help. Thank you.

    The blog I need help with is macidwebdesign.wordpress.com.

  2. Hey there,

    You can change your front page by going to Settings -> Reading in your blog's dashboard. From there, select "A static front page" as your home page, then select "Offerings" from the dropdown.

    The text below the slider is your blog title. You can change it by going to Settings -> General in your blog's dashboard.

    Let me know if I can be of any further help.

    Best,
    P.

  3. Hi!
    Thanks for responding. Great to know how to change that text in Settings-General. Thank you.
    But if I choose a static front page and select Offerings, I don't get the slider on the front page. How do I get the slider on the front page?
    M

  4. Howdy,

    The theme's description seems to indicate that the slider is limited to the default home page (with featured posts) only.

    Best,
    P.

  5. OK, Looks like the front page has to be a post page if I want the slider. So, I did that. But at the bottom of the front (Home) page it says "Nothing Found." What's that about?
    Thanks, P!

  6. We Volunteers cannot see into private blogs. I'll take a wild guess and say the 404 (page not found) error message http://en.support.wordpress.com/not-found/ on your front page -- was caused by you deleting the Hello World placeholder post. As soon as you publish a post, not a page http://http//en.support.wordpress.com/post-vs-page/ it will disappear.

    We Volunteers have lots of experience when it comes to using free themes. Forever threads are copious in number as we answer the same questions daily about the theme :) http://en.forums.wordpress.com/tags/forever

    http://theme.wordpress.com/themes/forever/
    Featuring posts in a slider on your home page is easy. You just need sticky posts with Featured Images. Every sticky post you have (up to 10) that has a Featured Image (at least 888 pixels wide) attached will show up there. They post slider will contain featured paosts. It will not automatically advance. The visitors have to click to advance the post slider.

    Note that Optimal size for featured images is: width 888px, height maximum 355px.
    http://en.support.wordpress.com/posts/post-visibility/#sticky-posts
    http://en.support.wordpress.com/featured-images/
    http://en.support.wordpress.com/featured-images/#setting-a-featured-image

  7. Hi timethief, I know you are a Forever expert judging by how often you answer these questions! But I haven't found answers to my questions there, sorry.
    Actually I have 5 posts published. But I still have this "Nothing Found" on my home page, and no "edit" link on the Home page either.
    I have the site visibility set to public. I thought you'd be able to see it?
    Thanks,
    mac

  8. This blog is set to private > http://macidwebdesign.wordpress.com/
    This blog is wearing React > http://macbookdesign.wordpress.com/

  9. Hi, how do I make macidwebdesign.wordpress.com public then? I've tried to find this info without asking you, but I don't see it. Thank you.

  10. Hi again,
    Support docs are here . http://en/support/wordpress.com
    here's the link > http://en.support.wordpress.com/settings/privacy-settings/

    Note: React is a premium theme and we Volunteers have next to zero experience working with premium themes. But don't despair as you piad for support direct from the theme designer and read-access to the premium themes forum is now open so you can search to see if your question has been previously asked and answered there. The premium theme forums are at http://premium-themes.forums.wordpress.com/ with separate sections for each theme. http://premium-themes.forums.wordpress.com/react/

    If you are not successful when searching there is a link for the specific Premium Theme support forum for your theme under Appearance -> Themes in your blog’s Dashboard, but do note that the premium theme must be active and you must be signed in as the user who purchased it in order to see it and post to it.

  11. I found it. Settings-Privacy. So now I hope it's visible.
    http://macidwebdesign.wordpress.com/
    Any help very appreciated!

  12. My questions are just about Forever on this site:
    http://macidwebdesign.wordpress.com/
    I have a "Nothing Found" on my home page that I'd like to go away. I've published 5 posts and it's still there.
    I think I have made the site public now so I hope you can see it.

    (This question is not about the "React" premium site)

  13. Hi again,
    It seems that the "Nothing Found" message relates to a search bar at the foot of my home page. I would like to remove this search widget, but the home page does not exist on my dashboard. It is just the front "page" chosen in Reading Settings: "Front page displays" and I chose " your latest posts." This was the only way to get the slider on the front page. The slider didn't display on a static front page. But since Home is not a real PAGE, I can't edit it. In this case I'd like to remove the search widget.
    This question refers to the Forever theme on this site which I hope is public and you can see:
    http://macidwebdesign.wordpress.com/
    Thanks so much for your help!
    mac

  14. I'm posting my findings here in case it will help others. I figured out that the "Nothing Found" message at the bottom of the Forever Home page is not a search widget; instead, it is there because in Theme Options I checked to have "Posts in Columns." For an unknown reason, nothing is found to show up on the home page. I tried sticky and non-sticky posts, with inserted images and with featured images. So this remains a mystery. But by unchecking the Posts in Columns option, I at least eliminated the "Nothing Found."

Topic Closed

This topic has been closed to new replies.

About this Topic