Need help? Check out our Support site, then


Forever Theme, Limit Posts on Home/Archives Page

  1. I need help limiting the number of posts on my homepage. The four columns of posts are all I would like to be seen on the front page of the site, rather than having unlimited earlier posts underneath. I check-marked "Show four of your latest posts in columns on your homepage" under Theme Options thinking that posts would not be shown after that. However, when I added a couple more posts just to make sure, posts started overflowing underneath the columns.

    I also went to Settings>Reading and now have "Blog pages show at most" set to 4 and "Syndication feeds show the most recent" set to 1 (because 0 is not an option) but these extra posts are showing past 1 so I am not sure whether I understand what these options mean (though I know that when I set "Blog pages show at most" to <4, the number of columns is reduced").

    Can someone please let me know how (or whether it is possible) to limit the posts on my homepage to just the four columns?

    Thank you!

    The blog I need help with is moiracunningham.com.

  2. Syndication settings are for your RSS feed, not for the site itself.

    On your main page, I see the 4 posts across the top and then two posts below that (full width). I'm not seeing a long list of posts.

    You can use CSS to hide the ones below if you wish.

    .home #primary {
    display: none;
    }

    Another thing is to try setting the blog posts show at most to 1 and see what happens. I don't thing that has anything to do with the 4 across the top of the page. That would still leave one below the 4.

  3. AWESOME! The CSS worked :-) Thank you so much.

  4. You are welcome.

Topic Closed

This topic has been closed to new replies.

About this Topic