Need help? Check out our Support site, then


Forever Theme - Post won't show on main page w/ proper image width

  1. Ok. I have tried everything that I've read in these forums and I must be missing one small item. When I create a post, add the sticky and featured image the post does not show up on the home page, but the image in the slider does. When I do not add a sticky or a featured image it does show up, but then I don't get the image in the slider. The image is 72 ppi and is 888 pixels wide. What am I missing?

    The blog I need help with is michellemonterophotography.wordpress.com.

  2. I'm not clear as to what you want to achieve here. If you do not want to have posts appear in the slider then why are you setting featured images in the posts and making them sticky posts? That's what you do when you do want to have featured posts in the post slider.

    Go to the footer of the theme and note the link there to the theme description:
    http://theme.wordpress.com/themes/forever/
    live demo site > http://foreverdemo.wordpress.com/
    This link is to all forum threads for that theme http://en.forums.wordpress.com/tags/forever

    Featuring posts in a slider on your home page is easy. You just need sticky posts with Featured Images. Every sticky post you have (up to 10) that has a Featured Image (at least 888 pixels wide) attached will show up there.

    Note that Optimal size for featured images is: width 888px, height maximum 355px.

    http://en.support.wordpress.com/posts/post-visibility/#sticky-posts
    http://en.support.wordpress.com/featured-images/
    http://en.support.wordpress.com/featured-images/#setting-a-featured-image

  3. I was under the impression that I could set a photo from a post as the feature and have that post appear on the home page. It doesn't appear that this can happen. I checked out a few additional Forever Themed sites and have found what I would like to do. Thank you for your response.

Topic Closed

This topic has been closed to new replies.

About this Topic